5 Replies Latest reply on Dec 7, 2014 3:51 AM by AlexT_Intel

    Compiling gspca for Edison

    hacktohell

      Hi,

       

      I am trying to compile the GSPCA kernel module for my Intel Galileo Generation 2, I am currently running ubilinux(Debian Wheezy).

       

      I downloaded the source and then tried making the module but I got an error,

       

      root@ubilinux:/home/gsca/usr/src/modules/gspca# make KVERS=3.2.0.4 KSRC=/usr/src/linux-headers-3.2.0-4-common/

      make -C /lib/modules/`uname -r`/build SUBDIRS=/home/gsca/usr/src/modules/gspca CC=cc modules

      make[1]: Entering directory `/lib/modules/3.8.7-ubilinux-0.9-quark/build'

      make[1]: *** No rule to make target `modules'.  Stop.

      make[1]: Leaving directory `/lib/modules/3.8.7-ubilinux-0.9-quark/build'

      make: *** [default] Error 2

       

      What do i do ?

        • 1. Re: Compiling gspca for Edison
          AlexT_Intel

          It looks like you're using a different version of sources (3.2.0-4) than Edison's kernel (3.8.7), I'd start with fixing that.

           

          I do have gspca_main and pac207 modules in my repo, so you can just extract them and use, if that's what you're up to. Double-check which kernel does the ubilinux use, if it's the same as with Edison's case (i.e. the kernel is the same as in the official image), then you should be fine.

          • 2. Re: Compiling gspca for Edison
            hacktohell

            Looks like I was trying to compile an super old version of gspca, in the newer ones(like the one in your repo) the camera drivers are all sub divided into several modules, and gspca_main simply binds them. https://www.kernel.org/doc/Documentation/video4linux/gspca.txt Your repository has only one of the submodule the module I need is gspca_ov519

             

            I am trying to compile the from the complete BSP sources for yocto, hopefully I will be able to compile the module myself

            • 3. Re: Compiling gspca for Edison
              AlexT_Intel

              I see. You should be able to, it's relatively easy. Just make sure you're using tested Linux distro as a build host (Ubuntu 12.04 x86_64 is definitely such one) and install the prerequisites per the BSP Build Guide. Then just do what section 4 of the guide suggests and enable the gspca modules you want: https://communities.intel.com/docs/DOC-23159

               

              Alternatively I can imagine that you could try to compile the same modules on Edison directly after installing the kernel-dev package from my repo using the process similar to the one you've tried to use initially (i.e. not Yocto but a traditional one). I haven't tried that, but it may work

              • 4. Re: Compiling gspca for Edison
                hacktohell

                (uhm I kinda switched to Galileo while compiling after accidentally downloading the BSP sources of Galileo, will try with edison later)

                So I compiled the kernel as per your instructions at Reconfiguring Linux kernel and adding drivers into Galileo's Linux image and also the BSP build guide and got the ipk file but now it says wrong architecture !!!!

                 

                root@dhcppc50:~/tmp# opkg install kernel-module-gspca-ov519_3.8-r0_clanton.ipk

                Unknown package 'kernel-module-gspca-ov519'.

                Collected errors:

                * pkg_hash_fetch_best_installation_candidate: Packages for kernel-module-gspca-ov519 found, but incompatible with the architectures configured

                * opkg_install_cmd: Cannot install package kernel-module-gspca-ov519.

                 

                So I appended

                 

                arch clanton 30 to /etc/opkg/arch.conf

                 

                Now I get

                * satisfy_dependencies_for: Cannot satisfy the following dependencies for kernel-module-gspca-ov519:

                *     kernel-3.8.13-yocto-standard *

                 

                Only then did I realize that I used to the wrong version of the linux kernel, I kinda sorta edited the .bb (recipe) file and pointed it to a local Git repo that I got from downloading the BSP source package(complete one - Intel® Download Center ). Anyway I do have the kernel ipk file so I am going to try and install it too :/

                 

                Why did the BSP pack have a newer kernel o0

                • 5. Re: Compiling gspca for Edison
                  AlexT_Intel

                  Hmm, yeah, looke like the kernel version is a bit messed up Galileo apparently doesn't have 3.8.13 yet.

                  Not sure if you can sort this out after all these changes during experimenting, maybe the best way would be to start from scratch and just build the module using standard BSP.