13 Replies Latest reply on Sep 25, 2015 2:21 AM by ivansky

    is WPA2 supported on Galileo Gen2 Yocto image?

    bsalimi

      Hi

       

      I'm trying to to connect to an enterprise network with no luck

       

      My wpa_supplicant.conf file has edited as :

      ctrl_interface=/var/volatile/run/wpa_supplicant

      ctrl_interface_group=root

      ap_scan=1

      eapol_version=2

      network={

      ssid="mySSID"

      key_mgmt=WPA-EAP

      eap=PEAP TTLS TLS

      pairwise=CCMP

      identity="myUSRNAME"

      password="myPASS"

      priority=2

      phase2="auth=MSCHAPv2"

      }

       

      has anyone  been authenticated to an enterprise network(802.1x) and can help me setup wifi on my device?

      I have no problem connecting to an open or WPA network .wired through Ethernet works perfectly fine too.

        • 1. Re: is WPA2 supported on Galileo Gen2 Yocto image?
          CMata_Intel

          Hi bsalimi;

           

          Have you tried scanning your networks, and setting the parameters as this websites sets: http://linux.die.net/man/5/wpa_supplicant.conf.

          Let me know about your results.

           

          Regards;

          CMata

          • 2. Re: is WPA2 supported on Galileo Gen2 Yocto image?
            bsalimi

            hi CMata,

            Thanks for your help and sending those links.Yes all the parameters are set correctly.

            My wpa_supplicant does get initiated however the PEAP authenticated doesn't seem to be happening. the wireless controllers see the device as associated (for 1 min only ) but not authenticated.

            The reason I know authentication is not happening is because I get the same result when I use real and fake credentials in the wpa_supplicant.conf file.

             

            Here is what I get after I enter the wpa_supplicant command :

             

            root@clanton:~# wpa_supplicant -D wext -i wlan0 -c /etc/wpa_supplicant.conf

            Successfully initialized wpa_supplicant

            [  480.236436] wlan0: deauthenticating from 00:24:6c:06:46:8b by local choice (reason=3)

            [  480.279484] cfg80211: Calling CRDA to update world regulatory domain

            wlan0: Trying to associate with [  483.393327] wlan0: authenticate with 00:24:6c:06:46:8b

            00:24:6c:06:46:8b (SSID='ocadu' freq=5805 MHz)

            ioctl[SIOCSIWFRE[  483.404385] wlan0: send auth to 00:24:6c:06:46:8b (try 1/3)

            Q]: Device or resource busy

            wlan0: Association request to the driver failed

            [  483.620124] wlan0: send auth to 00:24:6c:06:46:8b (try 2/3)

            [  483.627647] wlan0: authenticated

            [  483.640140] wlan0: associate with 00:24:6c:06:46:8b (try 1/3)

            [  483.649261] wlan0: RX AssocResp from 00:24:6c:06:46:8b (capab=0x411 status=0 aid=6)

            [  483.676353] wlan0: associated

            wlan0: Associated with 00:24:6c:06:46:8b

            wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started

            wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25

            wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected

            Illegal instruction

            wlan0: deauthenticated from 00:24:6c:06:46:8b (Reason: 3)

            [  572.048400] cfg80211: Calling CRDA to update world regulatory domain

            • 3. Re: is WPA2 supported on Galileo Gen2 Yocto image?
              CMata_Intel

              Hi bsalimi,

               

              Could you attach the configuration that you are using? The wpa_supplicant.conf with the setup of your network.

               

              Regards;

              CMata

              • 4. Re: is WPA2 supported on Galileo Gen2 Yocto image?
                bsalimi

                Hi CMata,

                 

                Here is the configuration files you asked for :

                 

                ###################################################################

                ctrl_interface=/var/volatile/run/wpa_supplicant

                ctrl_interface_group=root

                 

                ap_scan=1

                eapol_version=2

                network={

                 

                ssid="ocadu"

                key_mgmt=WPA-EAP

                pairwise=TKIP CCMP

                group=TKIP

                eap=PEAP

                ca_cert="/etc/cert.pem"

                identity="MY USERNAME"

                password="MY PASSWORD"

                #priority=2

                phase2="auth=MSCHAPv2"

                 

                }

                 

                ################################################################

                # /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

                 

                # The loopback interface

                auto lo

                iface lo inet loopback

                 

                # Wireless interfaces

                auto wlan0

                iface wlan0 inet dhcp

                        wireless_mode managed

                        wireless_essid any

                        wpa-driver wext

                        wpa-conf /etc/wpa_supplicant.conf

                 

                iface atml0 inet dhcp

                 

                 

                # Wired or wireless interfaces

                auto eth0

                iface eth0 inet dhcp

                iface eth1 inet dhcp

                 

                # Ethernet/RNDIS gadget (g_ether)

                # ... or on host side, usbnet and random hwaddr

                 

                iface usb0 inet static

                        address 192.168.7.2

                        netmask 255.255.255.0

                        network 192.168.7.0

                        gateway 192.168.7.1

                 

                # Bluetooth networking

                iface bnep0 inet dhcp

                • 5. Re: is WPA2 supported on Galileo Gen2 Yocto image?
                  CMata_Intel

                  Hi bsalimi

                   

                  I don't have an available network to use the configuration that you need. But I found this other link to initialize the wpa_supplicant. But I'm not sure about the interface that is used for that case.

                  Your configurations seems to be fine, but make sure that you are booting with the SDcard, and change the path (in  /etc/network/interfaces ) of:

                  wpa-conf /etc/wpa_supplicant.conf 
                  

                  to

                  wpa-conf /var/volatile/run/wpa_supplicant.conf
                  

                  The path of your wpa_supplicant.conf file.

                   

                  If still doesn't work try to add the configuration under the wpa-driver wext in  /etc/network/interfaces and erase the wpa-conf /etc/wpa_supplicant.conf line

                  Let me know it this works, I will try to search for someone using this configuration.

                   

                  Regards;

                  CMata

                  • 6. Re: is WPA2 supported on Galileo Gen2 Yocto image?
                    mhahn

                    Hi,

                     

                    wpa2 is 802.11i but not 802.1x I'd say. So not quite sure what you really are looking for.

                    In general I tend to use connman as described on IoT - Connecting Intel(R) Edison to an IEEE 802.1x Enterprise Hotspot via connman | Intel® Developer Zone (the blog is on Edison - but did likewise with Galileo on the Intel(R) IoT developer kit SD card eglibc/uclibc image)

                    • 7. Re: is WPA2 supported on Galileo Gen2 Yocto image?
                      bsalimi

                      hi cMata,

                       

                      The path of my wpa_supplicant.conf file is : /etc/wpa_supplicant.conf .

                      /var/volatile/run/ is where the wpa+supplicant ctrl_interface is .

                      I tried deleting wpa-conf /etc/wpa_supplicant.conf as you suggested but still not working,it doesn't even get associated with the AP.


                      note: the configuration under/network/interface is for when I try to connect using ifup wlan0 command, however I'm trying to connect using wpa_supplicant by running wpa_supplicant -D wext -i wlan0 -c /etc/wpa_supplicant.conf command.

                       

                      Now I'm trying to use cronnman as mhahn has suggested but the image does not have cronnman_tools and cronnman_client and I don't know how to install them at the momemnt .I will try to have those installed and see if cronnmon will help

                       

                      Thanks for your help

                       

                      Bsalimi

                      • 8. Re: is WPA2 supported on Galileo Gen2 Yocto image?
                        CMata_Intel

                        Hi bsalimi ;

                         

                        Take a look at the packages in the Alext's blog. There are the connman_tools and connman_client that you probably are looking for.

                         

                        Regards;

                        CMata

                        • 9. Re: is WPA2 supported on Galileo Gen2 Yocto image?
                          mhahn

                          you'd first have to initally "systemctl enable connman && systemctl start connman" before you can use it. You only have to run this once

                          • 10. Re: is WPA2 supported on Galileo Gen2 Yocto image?
                            CMata_Intel

                            Hi bsalimi

                             

                            Were you able to connect your board to your network?

                             

                            Best Regards;

                            CMata

                            • 11. Re: is WPA2 supported on Galileo Gen2 Yocto image?
                              ivansky

                              I'm not bsalimi, but I do have the same problem.  I have a few questions that follow on - perhaps we can turn this thread into a solved one.  Although if you'd rather I opened a completely new thread, please just say so.

                               

                              I have an enterprise Wifi network that I need to connect to (at my son's school) and have not been successful even after I was given the wpa_supplicant.conf file by someone in the networks section - he worked with a teacher at a different school to connect up a bunch of Raspberry Pi boards successfully with this config.  The wifi network is the same across all schools, btw.

                               

                              My /etc/wpa_supplicant.conf file looks like:

                              ctrl_interface=/var/run/wpa_supplicant

                              ctrl_interface_group=root

                              network={

                                ssid="EDU"

                                proto=RSN

                                key_mgmt=WPA-EAP

                                pairwise=CCMP

                                group=CCMP

                                eap=PEAP

                                identity="USERNAME"

                                password="PASSWORD"

                                ca_cert="/usr/local/share/ca-certificates/secure.cer"

                                altsubject_match="DNS:secure.domain"

                                phase1="peaplabel=0"

                                phase2="auth=MSCHAPV2"

                              }

                               

                              If I run "ifup wlan0", I get:

                              root@clanton:/etc# ifup wlan0

                              Successfully initialized wpa_supplicant

                              udhcpc (v1.20.2) started

                              Sending discover...

                              Sending discover...

                              Sending discover...

                              No lease, failing

                               

                              And a slightly different result but very similar to bsalimi's problem:

                               

                              root@clanton:/etc# wpa_supplicant -D wext -i wlan0 -c /etc/wpa_supplicant.conf

                              Successfully initialized wpa_supplicant

                              wlan0: Trying to associate with 18:ef:63:fd:da:d0 (SSID='EDU' freq=2412 MHz)

                              ioctl[SIOCSIWFREQ]: Device or resource busy

                              wlan0: Association request to the driver failed

                              wlan0: Associated with 18:ef:63:fd:da:d0

                              wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started

                              wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25

                              wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected

                              Illegal instruction

                               

                              I have other devices on the wireless network at this spot, signal seems to be pretty good.  I have tried the USERNAME and PASSWORD on my laptop, they are valid for this network.

                               

                              I keep running across suggestions to use the connmanctl commands, which look interesting, although I'm not sure they should be necessary, but I have yet to find a page that actually helps me install them!

                              For instance, "systemctl" does not seem to be on my board:

                              root@clanton:/etc# systemctl enable connmanctl

                              -sh: systemctl: command not found

                               

                              I tried hunting around a little in /usr/sbin and /usr/bin but couldn't find it.  If I need connmanctl to do further debugging, can anyone point me to information that will get it installed?

                               

                              P.S.  I have a Galileo Gen 2 board, we have successfully joined a home WPA2 network with this exact same board plenty of times, it is just the enterprise level one that is giving me problems. We are currently using an Intel Centrino Wireless-N 135 wifi board in the PCI express slot of the Galileo, if that matters.

                              • 12. Re: is WPA2 supported on Galileo Gen2 Yocto image?
                                mhahn
                                1. yes, it's better to start a new thread than to ask in an answered thread
                                2. if you want to give connman a try following hints on my blog might be of use for you IoT - Connecting Intel(R) Edison to an IEEE 802.1x Enterprise Hotspot via connman | Intel® Developer Zone. In that case you should rather remove your wpa_supplicant configuration again and leave it to connman to do the job
                                • 13. Re: is WPA2 supported on Galileo Gen2 Yocto image?
                                  ivansky

                                  Thanks for that, I have opened a new thread at Enterprise Wifi on Galileo using Intel Centrino Wireless-N card?

                                   

                                  I might also do some more looking because the suggestion to use connman still doesn't help - it's hard to "systemctl enable connman" when there doesn't seem to be any systemctl on the Linux distro I have.

                                   

                                  Thanks.

                                  Ivan