1 2 Previous Next 15 Replies Latest reply on Jul 31, 2015 3:28 AM by Rockwood

    Edison AP mode in 5GHz

    michaelpark

      I am using Edison module + Arduino board + ww42 image.

      I followed the instruction in Configure Edison (Access Point Mode) and it worked well.

      But it seems that it works in 2.4GHz mode.

      Is there any way to set Edison to work in 5GHz AP mode?

        • 1. Re: Edison AP mode in 5GHz
          Intel_Alvarado

          Hi michaelpark,

          That seems like a strange error, I tried it with my board and it connected with both a 5GHz and a 2.4GHz. How can you tell that it only works with 2.4GHz?

          Regards

          Sergio

          • 2. Re: Edison AP mode in 5GHz
            michaelpark

            Hi Sergio,

             

            First, I set Edison to AP mode. My Edison AP name is michael-edison.

            ####################################################

            root@michael-edison:~# iwconfig

            wlan0     IEEE 802.11abgn  Mode:Master  Tx-Power=31 dBm

                      Retry  long limit:7   RTS thr:off   Fragment thr:off

                      Power Management:on

            ####################################################

             

            Then I checked available AP list using WiFi Analyer application and found that it worked in 2.4GHz mode.

            Screenshot_2014-12-01-10-15-48.pngScreenshot_2014-12-01-10-16-03.png

             

            Best Regards,

            Michael

            • 3. Re: Edison AP mode in 5GHz
              mmi

              I don't use the Edison as AP but nonetheless this could be a solution.

              In my case the 5 GHz side of the AP has it's own mac address and a different ssid. I configured the client to connect only to this mac address/ssid. Just an idea, maybe this is also configurable for the Edison AP ?

              • 4. Re: Edison AP mode in 5GHz
                michaelpark

                Hi mmi,

                 

                Thank you for your comment.

                I don't want to make Edison to work as AP in both 2.4GHz and 5GHz simultaneously. I just want to set Edison to work as 5GHz AP mode.

                I tried "iwconfig wlan0 freq 5.18G", but it didn't work.

                #####################################################

                root@edison:~# iwconfig wlan0 freq 5.18G

                Error for wireless request "Set Frequency" (8B04) :

                    SET failed on device wlan0 ; Operation not supported.

                #####################################################

                 

                I also modified /etc/hostapd/hostapd.conf, but it didn't work.

                #####################################################

                hw_mode=a

                channel=40

                ieee80211n=1

                ht_capab=[HT40-][SHORT-GI-20][SHORT-GI-40]

                #####################################################

                 

                Best Regards,

                Michael

                • 5. Re: Edison AP mode in 5GHz
                  michaelpark

                  Is there anyone who set Edison to work as 5GHz AP mode successfully instead of 2.4GHz AP mode?

                  • 6. Re: Edison AP mode in 5GHz
                    han

                    In default Edison kernel, Regulatory DB is disabled.
                    So it is not allowed to use channel in 5Ghz area.

                     

                    This is steps what I tried to set 5Ghz channel for hostapd.

                     

                    1. Enable Regulatory DB in Kernel

                    See this link:
                    http://wireless.kernel.org/en/developers/Regulatory/CRDA#CONFIG_CFG80211_INTERNAL_REGDB

                     

                    2. Rebuild kernel and update edison image with new kernel

                     

                    3. Modify /etc/hostapd/hostapd.conf
                    For example, setting channel 44 in Korea.(channel 44: 5220 Mhz)
                    Set "country_code=KR"
                    Set "hw_mode=a"
                    Set "channel=44"

                     

                    4. run hostapd
                    systemctl stop wpa_supplicant
                    systemctl start hostapd

                     

                    You can check available channels using this command and use those channels.
                    "iw list"

                     

                    Thanks,

                    HJ

                    • 7. Re: Edison AP mode in 5GHz
                      michaelpark

                      Hi HJ,

                       

                      It works well! Thank you.

                       

                      Regards,

                      Michael

                      • 8. Re: Edison AP mode in 5GHz
                        mhahn

                        has someone managed to achieve the same by using crda?

                        Tried it but still failing

                        # COUNTRY="US" crda

                        Failed to set regulatory domain: -7

                         

                        "iw reg get" always lists country 00

                        • 9. Re: Edison AP mode in 5GHz
                          mhahn

                          will follow up on new thread

                          • 10. Re: Edison AP mode in 5GHz
                            Rockwood

                            Hi there

                             

                            I am trying same thing, but could not succeed yet. Maybe because of new firmware (ww05-15) or maybe I am doing something wrong, I am not so sure? I really appreciate if anyone can help. Thanks.

                            • 11. Re: Edison AP mode in 5GHz
                              mhahn

                              didn't work for me using crda. However, rebuilding the kernel as described worked fine.

                              • 12. Re: Edison AP mode in 5GHz
                                Rockwood

                                Can anyone please explain the process please? I am new to kernel building, I am trying by looking to both these pages:

                                Creating a Custom Linux Kernel for the Edison | Shawn Hymel

                                https://wireless.wiki.kernel.org/en/developers/Regulatory/CRDA

                                 

                                but could not succeed. Thanks.

                                • 13. Re: Edison AP mode in 5GHz
                                  Rockwood

                                  Here is some details of my process.

                                   

                                  I am using ubuntu derived linux:

                                   

                                  I downloaded edison-src-ww18-15.tgz from intels web site.

                                  Then I executed:

                                       sudo apt-get install build-essential git diffstat gawk chrpath texinfo

                                       libtool gcc-multilib

                                       sudo apt-get install libtool

                                       tar xvf edison-src-ww18-15.tgz

                                       cd edison-src/

                                  Then I run the script:

                                       meta-intel-edison/setup.sh

                                  When I execute the following command:

                                       source poky/oe-init-build-env

                                  I got the following errors and warning:

                                   

                                  WARNING: Host distribution "Ubuntu-16" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.

                                  ERROR:  OE-core's config sanity checker detected a potential misconfiguration.

                                      Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).

                                      Following is the list of potential problems / advisories:

                                   

                                      libsdl-native is set to be ASSUME_PROVIDED but sdl-config can't be found in PATH. Please either install it, or configure qemu not to require sdl.

                                  ERROR: Execution of event handler 'check_sanity_eventhandler' failed

                                  ERROR: Command execution failed: Exited with 1

                                   

                                  Summary: There was 1 WARNING message shown.

                                  Summary: There were 3 ERROR messages shown, returning a non-zero exit code.

                                   

                                  It is obvious that I am doing something wrong. Also I do not know what to do next and how to apply han's modification even I did not encounter these errors.

                                  Any help is appreciated. Thanks.

                                  • 14. Re: Edison AP mode in 5GHz
                                    Intel_Alvarado

                                    Hi,

                                     

                                    I believe your problem is:

                                    WARNING: Host distribution "Ubuntu-16" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.

                                     

                                    Take a look at this post Re: [HELP] Error message prompted when tend to customize the Yocto kernel which discusses some validated distributions.

                                     

                                    Sergio

                                    1 2 Previous Next