10 Replies Latest reply on Nov 27, 2014 2:20 AM by Igor_Terlevic

    Configuration job failing - A mandatory parameter is missing or empty (OSHostName).

    Igor_Terlevic

      Hi,

       

      I'm configuring Intel SCS console 9.1.2 to provision amt devices.

      I provisioned our test systems in admin mode using ACU_Wizard in windows with xml profile exported from SCS.

      Everything was ok (I can see the system in the SCS monitoring) except the Configuration Profile was not set.

       

      I tried to create a job (operation configuration) with the same profile to push it to all systems but it fails with this error:

       

      Operation:  Reconfiguration

      Date and Time: 20.11.2014. 13:29:12

      Error Code: 3221225979

      Severity: Failure

      UUID: 5D06FE00-85CF-11E2-8634-B4B52FC958A5

      Intel AMT FQDN: HRVcdPulaITE.calucem.local

      Intel AMT IPv4: 10.243.3.33                        

      Server Name: HRVvsPula040.calucem.local

      Description: A mandatory parameter is missing or empty (OSHostName). 

      The given profile require OSHostName.

       

      My profile have optional settings:

      - AD integration enabled (Always use the OS host name checked)

      - ACL enabled (ad group and 2 ad users (including myself) added to the list)

      - TLS enabled (CA is our CA server with server certificate template AMTRemoteConfiguration, CN in certificate: Default CNs)

       

      System settings

      - Edit IP and FQDN settings:

           - Use the following as FQDN: tried "primary dns fqdn" and AD FQDN

           - The device and OS will have the same FQDN (checked)

           - Source of the IP set to Get the IP from DHCP

           - DNS set to Update the DNS directly or via DHCP option 81

       

       

      I don't know if it's related to this but it looks like the kerberos auth is not working. When I try to connect to a test system using vnc client (encryption: TLS, connection mode: INTEL AMT KVM), it doesn't accept my domain account but asks me username and password for amt admin. If I enter it, I can connect successfully.

       

      I also noticed that if I start the acuconfig on the amt system to force it to pick up my profile, it works (but kerberos is still not working). After that I can see the profile applied in the SCS for that specific system.

      I'm using this command:

       

      ACUConfig ConfigViaRSConly RSC_Server_IP Profile_Name

       

      What am I doing wrong?

       

      Regards,

      Igor