10 Replies Latest reply on Nov 24, 2014 6:49 AM by mhahn

    Unable to flash custom image

    IntelAnonymous

      As suggested by AlexT_Intel I am posting my problem in a new thread.

       

      I created a custom image according to these guidelines Intel® Edison BSP User Guide . My system where I complied the image is a real desktop PC (no VM) using Ubuntu 14.04 32-Bit. I simply added some packages via IMAGE_INSTALL and a driver within the following files:

       

      device-software/meta-edison-distro/recipes-core/images/edison-image.bb

      device-software/meta-edison/recipes-kernel/linux/files/defconfig


      After building my custom image I executed device-software/utils/flash/postBuild.sh. The following files were created:

       

      Filelist.PNG

      u-boot-envs includes

      Filelist1.PNG


      I want to mentioned that "ota_update.scr" has only been created after performing the instructions of lrosenman: Custom Linux Image -- no ota_update.scr? | Intel Communities .

      I copied all files to the Edison drive which was empty. Afterwards I logged into the Edison via SSH, typed reboot and hit a key to end up here:


      reboot.PNG

      I entered "run do_ota" and got the following output. The red box indicates where I expect the problem


      run_ota2.PNG


      Result: The Edison simply boots without flashing my image.

      I hope my description is not overloaded with too many details.

        • 1. Re: Unable to flash custom image
          mhahn

          why not just run the "flashall" script rather than trying ota?

          • 2. Re: Unable to flash custom image
            IntelAnonymous

            Thanks for the hint. I have not paid much attention to the flashall.sh/bat since I thought flashing is done as described here:

             

            https://communities.intel.com/docs/DOC-23192#jive_content_id_Step_5__Flashing_Edison

             

            I will try flashall this afternoon and report.

            • 3. Re: Unable to flash custom image
              mhahn

              pls note several threads within this forum on "flashall". If running on Linux make sure to run as sudo

              • 4. Re: Unable to flash custom image
                IntelAnonymous

                Since I am currently using Windows 7, I tried flashall.bat (using cmd with admin rights). Here are my results:

                 

                1. At first I got a message about missing file dfu-util.exe. Solved with this thread: dfu-util for Windows I downloaded the dfu-util.exe and put it in the "toFlash" folder.
                2. Afterwards I had to apply a more stable power source since my edison rebooted all the time (I also found the solution in the intel forums).
                3. Finally I executed flashall.bat, logged into my edison and typed "reboot".  After "Ready to receive application" some seconds passed but in the end I still get the "Flashing already done..." message and my system is unchanged.

                 

                Edison:

                flashing.png

                 

                CMD:

                cmd.PNG

                If I try the --recovery option I get a message about the missing xfstk tools (which are only available for linux).

                • 5. Re: Unable to flash custom image
                  mhahn

                  pls check the other threads on flashall - a modification to the script is shown there which allows recovery without xfstk afaik

                  • 6. Re: Unable to flash custom image
                    IntelAnonymous

                    I just tried another computer. With this computer and the same edison and the same custom image the flash process worked.

                    Therefore I expect that the USB Hub current supply of the PC I used yesterday was still not sufficient.

                     

                    After the flash process you get a message that the edison will reboot twice. The second time the edison reboots you finally get the message from above ("Flashing already done...").

                    My custom packages such as nano are now available.


                    I hope my expierences are helpful for others.

                    • 7. Re: Unable to flash custom image
                      IntelAnonymous

                      I apologize but the problem still persists. In fact I am only able to flash images when I am using a specific docking station from DELL.

                       

                      I have two Edison Arduino Breakout Boards (the big ones). Successive is what I have tried so far:

                       

                      1. Laptop A USB power supply (no flashing possible for both boards)
                      2. Laptop B USB power supply (no flashing possible for both boards)
                      3. Desktop PC USB power supply (no flashing possible for both boards)

                       

                      So I tried to use a laboratory power supply. According to Section 3 in edison-arduino_HG_331191-002.pdf I applied 15V with a maximum of 1.5A to J1.

                      Result: The edison booted while using approx. 100-200mA but flashing was also not possible for both boards.

                       

                      So I tried to use the USB-Port of my DELL PW380 docking station. When using this docking station the flashing process is reproducible for both boards.

                       

                      Now I am very unsure If I am doing sth. wrong or if the edison flash process is only possible if very specific voltage and current limits are kept?

                      • 8. Re: Unable to flash custom image
                        deium

                        IntelAnonymous if you are able to flash from the docking station and not the laptops, my question would be are you using the exact same cables on both the docking station and laptops.

                        If you are using different physical cables, there are known reports of some micro USB cables that do not work.  I'd test your cables used at the docking station with the laptops.

                        Also check, do the laptops have the drivers installed.

                        I am able to flash my Edison if my console cable is connected by one microUSB cable on J3, and powered by microUSB cable on J16, on the mini breakout board.

                        • 9. Re: Unable to flash custom image
                          IntelAnonymous

                          Hello deium,,

                           

                          I tried using the same cables all the time. Actually I have no clue why it is not working (or better: only working with the docking station and not even with an external power supply).

                          • 10. Re: Unable to flash custom image
                            mhahn

                            Would OTA flash work?