3 Replies Latest reply on Nov 17, 2014 12:59 PM by AlexT_Intel

    Gain root shell access

    IFarkas

      As I was going through the Getting Started steps I modified the root password.

      To my biggest shock on reboot it was not recognized.

      I tried all listed tricks, non worked. "run do_ota" did flush, but root still asks for a password.

      Thank you very much for your help in advance.

        • 1. Re: Gain root shell access
          AlexT_Intel

          What do you mean by "did flush"? If you have an image copied to the Edison's update area (shown as disk drive when you connect it to the Windows computer), then "run do_ota" willl reset the board's OS to the default state, including configurations and passwords. If you don't have that after running the OTA, capture the console output for the whole process (starting with "run do_ota") and post here, we could check what's going on there.

          • 2. Re: Gain root shell access
            IFarkas

            I tried again and it worked. Here are the steps for the Arduino board:

            1. Get latest Edison Yocto complete image
            2. Connect PuTTY
            3. Hold the PWR button till Edison shots down (~8 sec)
            4. Press the PWR button again to boot Edison
            5. Hit a key when the Hit any key to stop autoboot message appears (have to be quick)
            6. Type run do_ota

             

            Thx, Alex

            • 3. Re: Gain root shell access
              AlexT_Intel

              You're welcome & that's correct. You can use the Reset (SW1UI5) button instead of the Power one, will be a bit faster.