5 Replies Latest reply on Nov 28, 2014 5:08 PM by CMata_Intel

    Arduino/Gen2 com. issues

    pdx4s

      This is ridiculous, I am trying the third Gen2 board and the board/Arduino still not communicating properly.

      First two got bricked when trying to update fwr, I followed the start-up guideline to the letter including the latest Arduino rev, it got stuck in Step4.2-Go to Help -> Firmware Update - nothing happens, after >1hr waiting tried to kill the Arduino app. on the PC which bricked both of them (USB driver was worthless after that).

       

      On the 3rd unit, I decided to try loading the Blink file command before going to step4, so now its stuck in "Uploading"

      Here are the messages:

       

      Binary sketch size: 83,463 bytes (of a 10,000,000 byte maximum) - 0% used
      cygwin warning:
        MS-DOS style path detected: C:\Galileo\arduino-1.5.3-Intel.1.0.4/hardware/arduino/x86/tools/izmir/clupload_win.sh
        Preferred POSIX equivalent is: /cygdrive/c/Galileo/arduino-1.5.3-Intel.1.0.4/hardware/arduino/x86/tools/izmir/clupload_win.sh
        CYGWIN environment variable option "nodosfilewarning" turns off this warning.
        Consult the user's guide for more details about POSIX paths:
          http://cygwin.com/cygwin-ug-net/using.html#using-pathnames
      #!/bin/sh

      echo "starting download script"
      starting download script
      echo "Args to shell:" $*
      Args to shell: C:\Galileo\arduino-1.5.3-Intel.1.0.4/hardware/tools/x86/bin C:\Users\QX\AppData\Local\Temp\build4927286230808784195.tmp/Blink.cpp.elf COM4

      COM PORT 4
      # ARG 1: Path to lsz executable.
      Converted COM Port COM4 to tty port /dev/ttyS3
      # ARG 2: Elf File to download
      Sending Command String to move to download if not already in download mode
      # ARG 3: COM port to use.

      #path contains \ need to change all to /
      path_to_exe=$1
      fixed_path=${path_to_exe//\\/\/}

      #COM ports are not always setup to be addressed via COM for redirect.
      #/dev/ttySx are present. Howwever, COMy -> /dev/ttySx where x = y - 1
      Deleting existing sketch on target

      com_port_arg=$3
      com_port_id=${com_port_arg/COM/}
      echo "COM PORT" $com_port_id
      tty_port_id=/dev/ttyS$((com_port_id-1))
      echo "Converted COM Port" $com_port_arg "to tty port" $tty_port_id

      echo "Sending Command String to move to download if not already in download mode"
      echo "~sketch download" > $tty_port_id

      #Move the existing sketch on target.
      echo "Deleting existing sketch on target"
      $fixed_path/lsz.exe --escape -c "mv -f /sketch/sketch.elf /sketch/sketch.elf.old" <> $tty_port_id 1>&0

       

      Any suggestions ? I'm running out of ideas

        • 1. Re: Arduino/Gen2 com. issues
          Intel_Peter

          Hello pdx4s,

           

          Are you sure you are following this guide? If so make sure you're using the correct power supply (2A @ 7v-12v), always remember to connect the power supply before the USB port otherwise it could result in damage to your Galileo. Something that could be causing your issue might be a corrupted file on the download or decompressing, so make sure you download the latest software for your Galileo in here.

           

          Regards,

                      Peter

          • 2. Re: Arduino/Gen2 com. issues
            DinoT_Intel

            That issue usually happens when you select the wrong com port. Make sure you are using the correct com port.

            Also try rebooting or alternatively, go to task manager and kill the bash.exe and lsz processes.

             

            Also do you have access to the console of the Gen2? Does it boot fine?

            • 3. Re: Arduino/Gen2 com. issues
              pdx4s

              hmmm.."when everything fails read the manual" ?

              well folks I could use a bit more credit than that, of course I use the start-up guide, and yes the correct ports/device were selected,

               

              Anyway, I didn't had a chance to post that evening but after placing the original note I made few more trials:

              1. installed the drivers on another PC (tablet PC with only one USB port) and for my surprise all went fine, including Blink, didn't tried yet fwr update check command as I'm still afraid of possible getting it bricked but this was a major improvement;

              2. went back to my desktop and tried another USB port, same issue, when I connected it to the third USB port, it detected it as COM5 and Bingo it worked same as in step 1.

              Conclusion: not all USB ports are the same or the Gen2 USB driver is not quite plug-n-play as advertised. My take its a little of both, marginalities are usually the cause to similar issues, I don't have an issue with any other device using the same ports that didn't worked with the Gen2. Also I wonder if there isn't a collision some where between the com ports/IRQ ?

               

              BTW, the BKM I hear from some users is that they don't rush to follow the start-up steps due to concerns with the fwr update step. May need to get more folks to say why.

              Now I have another issue IDE app. doesn't open on the screen, it just had the developer page for few sec's and then nothing, trying to reboot.

              • 4. Re: Arduino/Gen2 com. issues
                Intel_Peter

                Hello pdx4s,

                 

                I can see from the picture you attached before that you are using Windows 7, some other users have had the same issue, the window shows for a sec and disappears soon. In the link below you will find a post where this issue is already resolved. Please let us know if this resolves your issue.

                 

                Cannot open the Arduino in win 7

                 

                If you have any more doubts, don't hesitate to ask.

                 

                Regards,

                            Peter

                • 5. Re: Arduino/Gen2 com. issues
                  CMata_Intel

                  Hi pdx4s

                   

                  Were you able to communicate your Galileo Board with your IDE?

                   

                  Regards;

                  CMata