3 Replies Latest reply on Sep 21, 2015 9:52 AM by qiki

    Yocto build error in nodejs do_install

    Parthiban

      Dear All,

       

      I tried my first build with Yocto and the build failed in nodejs do_install step. If restart the build process without doing any changes, the build success. Please find the attached logs. Kindly help.

       

      Thanks,

      Parthiban N

        • 1. Re: Yocto build error in nodejs do_install
          mhahn

          not sure but seems there is an issue with the hash sums of the tarball:

           

          SHASUMS.txt defines: "node-v0.10.28.tar.gz":"ef08a75f6359a16e672cae684e0804ca7f4554b7"

          however

          node-v0.10.28.tar.gz local sha1 0575552fb5bf2e8937f600044016ae906604af98 not match remote ef08a75f6359a16e672cae684e0804ca7f4554b7

           

          So maybe transmission error? Maybe retry?

          • 2. Re: Yocto build error in nodejs do_install
            Parthiban

            Hello mhahn,

             

            Thanks for your response.

             

            Yes, my download might have broken in between. But why raised this in forum is because, when I tried building in my workstation with very good reliable network connectivity, this was failed with the same step.

             

            Second time failed in my laptop on personal home network. So I just thought posting to the forum. May be I re-raise the same question if it occurs again (for sure I will not running into that as Fresh Yocto build = 5-6 hrs :-( )

             

            Thanks,

            Parthiban N

            • 3. Re: Yocto build error in nodejs do_install
              qiki

              I fixed such problem by trying to download the package manually and copy it to download directory. Re-bitbake again, normally the error will disappear