2 Replies Latest reply on Nov 8, 2014 2:07 AM by ivansky

    blink won't blink anything on Gen 2 board?

    ivansky

      Hi everyone.  My son's school has bought some Galileo Gen 2 boards and we are playing with one this weekend to begin becoming familiar with them.  Although I have an ICT background, I do not have any experience with these (or Arduino) boards, and we are a bit stuck in the "Getting Started" stage.  We have Googled and read for a while today trying to figure out our problem, but we are still stuck and I wonder if anyone can help?

       

      Here is the problem.  We followed the Getting Started guide and downloaded the "Arduino" software for our Mac laptop from Intel Communities, this runs up fine and after a bit of Googling we found how to select the correct device and we think we are talking to the board OK.  One guide told us to upgrade the firmware but that option tells us we are on 1.0.2 and asks if we want to install older 1.0.0, we declined.

       

      The board is definitely powering up as we have couple of LEDs lit. We can "Upload" the blink example and receive a message "Transfer complete" after a few seconds.

       

      However, nothing blinks.  At first we weren't even sure if pin 13 had an LED, then I found that someone has asked about this in the following thread:

       

      https://communities.intel.com/thread/55517

       

      In that thread, Diego very helpfully posted a photo showing the LED that is apparently associated with pin 13.

       

      So as far as I can tell, we should be seeing an LED (that seems to be labelled "L") blink once every second.  However, nothing blinks.  We connected a multimeter to pin 13 and the adjacent pin GND and don't see any voltage.

       

      We tried resetting the board, powering down the board, restarting numerous times etc.  All the basic obvious stuff.  What I am wondering now is if there is any more simple debugging I can do, to determine whether the board is perhaps faulty, or if anyone has any other suggestions?  I do not know how to proceed.  We do not have a serial connection, and we have not loaded any other examples.  Is there anything else I should try that is simple?


      Thanks.

      Ivan

        • 1. Re: blink won't blink anything on Gen 2 board?
          flummer

          Hi Ivan,

           

          I'm guessing a bit here, but I have a feeling that you are not on the latest version of the IDE (the firmware update shouldn't try a downgrade). I would suggest to try out the latest version from Galileo Software Downloads.

           

          The version numbers was a bit weird to begin with (all called 1.5.3), but lately they have added an additional number at the end that increments, It's on 1.5.3-Intel.1.0.4 now and should also reflect that in the window titlebar.

           

          In the Tools -> Boards menu, there will be a total of 3 different boards, "Intel Edison", "Intel Galileo" and "Intel Galileo Gen 2", and it's of course the last one you need to pick.

           

          If I'm not mistaking, the onboard LED has it's own I/O, but it's hooked up in software by the IDE to blink with pin 13 (to be compatible with the regular Arduino).

           

          I hope it helps, if not, we will need to dig in a bit deeper ;-)

           

          /Thomas

          • 2. Re: blink won't blink anything on Gen 2 board?
            ivansky

            Thank you flummer.  We only loaded the software today, but somehow Google led us to a slightly out of date version.  I was running 1.5.3 as you thought, and when I followed your link I was able to download the latest 1.5.3-Intel.1.0.4, and that worked straight away.  Very much appreciated!

             

            Ivan