4 Replies Latest reply on Nov 11, 2014 10:01 PM by Chamayo

    Robopeak and Windows image

    Chamayo

      Anyone able to install the LIBUSB drivers into the Windows image for the Intel Galileo in order to use the Robopeak USB display?

       

      I'm not able to install the drivers into the image before booting it up for the first time. I'm also unable to install the drivers through the command prompt after booting up the image.

        • 1. Re: Robopeak and Windows image
          JPMontero_Intel

          Hi Chamayo

           

          I’d suggest you to post this in the Windows IoT community for this image https://dev.windows.com/en-us/featured/windows-developer-program-for-iot . Maybe they can give you a more accurate response.

           

          Regards,
            JPMontero_Intel

          • 2. Re: Robopeak and Windows image
            Chamayo

            I know the Windows installation for the Galileo does not have GUI support, but I would at least like to draw a line on the screen using Visual Studios. That would require me to have the drivers installed at least.

             

            I'll check it out Mr. Montero!

            • 3. Re: Robopeak and Windows image
              dferyance

              I am hoping someone will contradict me but I am expecting what you want to do isn't possible. I tried to find a DDK for Windows on Galileo and came up with nothing. So I don't think you can compile a driver for the board -- at least not with a vendor supported method. One of the great things about Galileo on Linux is you can install drivers and mess with the kernel. While I had high hopes for Windows I jumped back to Linux pretty quickly because of this.

              1 of 1 people found this helpful
              • 4. Re: Robopeak and Windows image
                Chamayo

                Robopeak can't be contradicted because they do in fact offer Windows support for their display, although not on the Galileo. It runs beautifully through a computer but then what's the purpose of placing a Galileo in-between the story? Sure it runs spectacular on their Linux image that contains the rpudisplay drivers but their translation didn't come true clearly as you can't SSH or Telnet to it through network (simply, the network setup is not started up automatically or a sketch is not allowed to be run before the OS boots up to activate the network.)

                 

                I tried Devcon and whatnot previously used method, and even the ol' libusb way through the command line installer. The ol' way was before the GUI installer was introduced so I'm not sure the creators of the LIBUSB32 want to mess around with older methods than what they used to do.

                 

                So I ordered a $10 serial cable for my Galileo so I can root into the Robopeak Linux image and configure the network and the resolution (darn the screen looks beautiful but I can barely navigate through it.)

                 

                I'm sure going to miss being able to draw at least a line through Visual Studios on my Galileo especially since I will be starting to practice for my Microsoft Specialist certification again soon.

                 

                Thanks for your help. It's like not being able to upload sketches through WiFi on the Galileo, as you can't even install a driver for at least a USB display.