10 Replies Latest reply on Aug 1, 2015 10:34 AM by RzR

    DE3815TYKE (Atom) Linux reboot freezes box

    phix

      Dear all,

       

      our issue is quite simple: the NUC often hangs and freezes if we want to reboot it.

      Facts:

      7 NUCs from three different Shops tested (three different S/N groups)

      RAM: Kingston KVR16LS11S6/2 2GB DDR3L SO-DIMM

      Storage: Internal MMC Flash

      OS: we tried OpenELEC, ArchLinux, Fedora 20

      BIOS: 0032, 0034, 0036

      BIOS Settings: all different settings tried. Static settings were: Legacy boot enabled, eMMC enabled, OS Linux.

       

      What's wrong in detail:

      If we issue a reboot command on the box, it shuts down X-Server, shuts down all Task, etc. (Serial console debugging has finished too!) and when the kernel tries to reboot the box may hang.

       

      Yesterday we had 3 NUCs in a loop-reboot (reboot every minute) during the night. All three boxes rebooted as they should. I then took one box, applied another BIOS settings => hang!

      I removed that bios setting again => still hangs every time (although it was working the whole night... ).

       

      We tried different BIOS versions and settings. We tried different linux reboot commands: even the most brutal force-reboot hangs

       

      One of that seven boxes seem to definitely broken, as it refuses all BIOS updates, but all seven?

       

      What can we exclude so far:

      * different linux distros and kernels. We tried many! Kernels from 3.16.3 up to 3.17.2

      * BIOS settings like EX Prevention Disable, Power settings

      * BIOS versions

       

      What really drives me crazy is that it seem only we got this issue, no other findings here or on Google.

       

      Currently a coworker is trying to get different RAM modules (we only have 1,5V ones here and they definitely do not work), because this is my last "hope" as all seven NUCs uses the same RAM model.

       

      Any ideas from the community?

       

      Thanks in advance ;-)

       

      PS: Yes, we also tried all the HowTos and Guides from the Intel support pages