3 Replies Latest reply on Nov 7, 2014 2:56 PM by jakeh

    Yocto - IMAGE_INSTALL not being read

    jakeh

      A little background: the end goal is to get GNURadio running on the Edison. I have successfully built the stock Yocto image (on a Linux VM) following this tutorial: Intel® Edison BSP User Guide

       

      The first parts worked correctly. I added the OpenCV package and rebuilt the image as described in section 3.3 in the above document. This worked. But when I try to add other packages to the IMAGE_INSTALL variable in the build/local.conf file and rebuild again, it doesn't work. As in, when I run bitbake edison-image it doesn't build/install any additional packages. It goes through the preliminary motions, but then at the end it says "NOTE: Tasks Summary: Attempted 2802 tasks of which 2802 didn't need to be rerun and all succeeded." which implies that the packages were not added nor built.

       

      However, I can add the same package names to IMAGE_INSTALL in the file edison-src/device-software/meta-edison-distro/recipes-core/images/edison-image.bb and it works fine - it goes through the whole build process as normal for the new packages. So it appears that it is ignoring the IMAGE_INSTALL settings in local.conf.

       

      I've looked at the output of 'bitbake -e edison-image' and the package names appear, but I have no idea why it's not being built.

       

      Any ideas what's happening? Are there compatibility/version issues that bitbake is silently ignoring? Any advice would be greatly appreciated.