4 Replies Latest reply on Nov 3, 2014 9:52 AM by guypld

    Problems with intel-iot-devkit 'mraa' library

    guypld

      Hi,

       

      I've downloaded the latest SD Card image from here:

      Galileo Software Downloads

       

      and the library (Low Level Skeleton Library for Communication on GNU/Linux platforms)

      intel-iot-devkit/mraa  

      from here : https://github.com/intel-iot-devkit/mraa

      and installed as described (with opkg).

       

      When I tried to run the python example (blink-io8.py) I got the following error:

       

      root@clanton:~/mraa-master/examples/python# python blink-io8.py

      Traceback (most recent call last):

        File "blink-io8.py", line 25, in <module>

          import mraa

        File "/usr/lib/python2.7/site-packages/mraa.py", line 32, in <module>

          _mraa = swig_import_helper()

        File "/usr/lib/python2.7/site-packages/mraa.py", line 28, in swig_import_helper

          _mod = imp.load_module('_mraa', fp, pathname, description)

      ImportError: File not found

       

       

      Also tried to run the example from the web site http://www.pridopia.co.uk/intel-galileo.html

      the library ' GPIO_intel_v10 --  V1.0', and the output was:

      root@clanton:~/py# python Test.py

      Initial Setup.

      Traceback (most recent call last):

        File "Test.py", line 36, in <module>

          Gpio.setup('IO2')

        File "/home/root/py/lib/GPIO_Intel.py", line 104, in setup

          self.cmd('1', '/sys/class/gpio/gpio{}/value'.format(activate))

        File "/home/root/py/lib/GPIO_Intel.py", line 97, in cmd

          with open(file, 'w') as File:               # Very slow write speed compared to Raspberry Pi / Compiled Arduino Sketch

      IOError: [Errno 2] No such file or directory: '/sys/class/gpio/gpio31/value'

       

      it used to work..

       

      please help me with that.

      Thanks.