7 Replies Latest reply on Nov 3, 2014 11:28 AM by r2d2222

    s5000sva, web console, can't find server, Small Business Server 2008


      We have a s5000sva board and I am attempting to create a RAID array using the boards embedded controller using 4 1.8TB drives after having installed the OS to an 80 GB Drive.  I have ruled out using the RAID BIOS function as it appears non-compliant with what we are needing and have decided to attempt to create this huge RAIDED array post OS install using the web console.  However, when I install the software after running the network wizard on the server running small business 2008, it reports that it cannot find the server on the network.  I am hypothesizing that my next step will be in the direction of acquiring the right driver that will allow this software to function correctly with the platform.  Can anyone offer assurance I am headed in the right/wrong direction?  Thank you.

        • 1. Re: s5000sva, web console, can't find server, Small Business Server 2008

          During the Operating System installation, it should ask you to install the network driver to move with the configuration but it should give you the change to load it at that moment. I am not sure why it is not finding your network. Are you able to provide a screenshot of the screen you are at?

          • 2. Re: s5000sva, web console, can't find server, Small Business Server 2008

            Hi David, Thanks.


            I opted to go with the after-OS load of the RAID driver as (as I understand it) during the initial setup using the Intel BIOS RAID setup, in order to create a bootable volume with the embedded RAID controller (unlike with my old 3ware card that allowed me to configure one single stand alone disk to boot the OS with this MRB partition) I would be able to select a boot volume ONLY if I were to RAID either a 0 or 1 configuration using two disks to boot from, allowing me to select another three disks and RAID these forming what I thought would be a RAID 5 array, that is, until I saw that I was only able to use RAID 0,1,or 10 due to the restrictions set forth by the lack of additional keyed hardware allowing me to use a RAID 5 array, thusly, limiting my options to the need for one OS MBR disk and one RAIDED volume (RAID10) ... that limit, created by the number of ports on the board.  RAID 10 needs 4 discs.  That, plus the port for my Optical drive leaves me with one port left for my MBR OS disc.


            So, I headed down towards folly land trail with attempting to use the web console (local host install) in order to load the OS on one drive and then to attempt to create the RAID volume this way.  This route still concerns me as I had to configure the boards BIOS for AHCI instead of RAID pre-OS install.  (I read in one forum where a lady stated that you could set to RAID, install on one physical Drive and it would "intelligently" revert to AHCI only for this drive).  Problem is, when I attempted to load the OS with the board's BIOS set to RAID - no such thing apparently occurred, leaving me with no drives available.  Perhaps it would have if I had loaded the RAID driver at that point, but would it have shown me a stand alone 80 GB drive? After I set the boards BIOS back to AHCI, the drive was available for me to load the OS.


            Do I need to start over and still set the S5000VSA's BIOS to RAID and load the driver.  Will the OS load read the drive there with the RAID driver installed at that point or will it still not be present as the stand alone disk (to accomplish RAID 10 with my physical SATA port limit), do I proceed with fumbling with the non-.exe RAID driver that is loadable post OS install?  None of the above?


            Where I am currently: 5 total drives attached to the board's SATA ports, one of which is an 80 GB MBR OS volume and the other 4 are 1.8 TB I am wanting to RAID and format GPT to show as much storage as possible using either 5 or 10 (preferably 10 at this point).  The OS is loaded with Small Business Server 08 and I, in attempting to install the RAID driver, deleted the storage controller in the hopes to install the RAID driver and now it is gone = no more storage controller listed there for me to update the driver (unless it is hiding under a sub category).  But show hidden devices does not produce any devices without drivers installed.  I got this idea from the read me file on the RAID driver folder.  (ESRT2 RAID driver for Windows)  and reads as follows:


                 "Installation of the driver after the operating system is installed:

                 1. Boot into applicable Windows OS. Click the Windows Start button and select Settings.
                 2. Click Control Panel.
                 3. Select Adapter.
                 4. Select the Drivers tab.
                 5. Scroll down the list until the appropriate selection for your system which contains the Intel(r) Embedded RAID Technology II and for your operating      system displays, then click <OK>.
                 6. Select it, then remove it by clicking the Remove button.
                 7. Click the Add button.
                 8. Select the Have Disk button.
                 9. Insert the diskette into the floppy drive.
                 10. Select drive letter A: and click on <OK>.
                 11. Select Intel(r) Embedded RAID Technology II and click OK.
                 12. After Windows* copies the driver, reset the system."


            But, I can find no driver listed to replace other than the storage controller I listed.


            Is it back to the drawing board for me?  Am I limited to RAID 10?  Is RAID 5 really not an option without the unlock hardware key?  With 5 ports available, can I use one stand alone disk (80GB) to load the OS and one volume with 4 1.8 TB drives?  Am I understanding correctly that the Intel board design only allows me to use a bootable volume in conjunction with another RAID array if that volume itself (the boot volume) is Raided with 0 or 1?


            Should I wait for me 3ware card to get here?


            Thank you!




            • 3. Re: s5000sva, web console, can't find server, Small Business Server 2008

              In this particular case, you should be able to install your Operating System in your 80GB drive.  This way, you would need to configure your 80GB disk as a standalone RAID 0 drive for your Operating System to see the drive during the installation. You would still need to load your RAID driver to install the operating system.


              It is not required for the bootable volume to be a RAID 0 or RAID 1 volume. As a matter of a fact, you should be able to create both volumes at the same time and then install the operating system. And yes, you need to get the RAID Activation Key (AXXRAKSW5) to enable RAID 5 support.

              • 4. Re: s5000sva, web console, can't find server, Small Business Server 2008

                I am hopeful I can check the "correct answer" box in the am.  Had a sick day.  Thank you.


                So, as I understand it, I can use these 5 drives to acquire a RAID 10 using the Intel embedded controller on the S5000VSA board without the hardware key by assigning, in the RAID BIOS utility, the 80 GB drive to be the bootable drive, which I think is called, at that point "volume 0," or something to that measure, and, even before installing the OS, be able to create, also, the second RAID array from the other 4 drives using RAID 10, of course, with loading the RAID driver at the point where the load program looks for a destination drive to load the OS?  At that point, with these aforementioned provisions, there should be 2 available "volumes" there: the 80GB and one other pretty large 3.5 TB (approx.).  I then select the 80 GB drive and when the OS finishes loading, I am able to load the only missing driver as it were (network driver) as I did on previous attempts, and at that time, the web console would show my server available to manage the RAID configurations, to include then being able to use disk manager to format the larger volume for GPT to extend beyond 2TB?


                My only other wonder is in regards to the way we assign the bootable drive as we are confined to 1 drive for the OS given the only available RAID type (10) and the number of physical SATA ports on the board.  Here is the wording from the manual:



                     "Follow these steps to configure a bootable virtual drive:


                      1.From the Main Menu, select Configure | Select Boot Drive.

                     2.Select a virtual drive from the list to make it the designated boot drive."


                That's it, that is all is says ... "virtual," which is why I thought that the boot drive would also HAVE to be Raided. But what is this you say?  I can create a virtual RAID 0 for this 80 GB drive to enable me to use it in the board's RAID SATA mode, without it being an actual raided device?  That would be great!


                No where (that I found) in the manual did it read where I could create this bootable volume as "standalone," nor is the word "standalone" located in the manual (other that in regards to the installation of the web console, but alas ... I have hope.




                I'll let you know how it goes tomorrow.  Thanks again. 

                • 5. Re: s5000sva, web console, can't find server, Small Business Server 2008

                  OK, for all followers of this thread, I am replying to my own post this morning.


                  All seems to be going well with having done the previous steps.  I was even able to create a RAID 0 from one disk on which to load the OS which is currently loading.  I could even see both volumes prior to loading the driver (perhaps because the raid driver was already on the hard drive)?


                  I did hesitate and return to the thread when I scanned my flash drive for available RAID drivers and the system showed me 2.


                  I chose the R2 version (64 bit) of the driver and the second listed when it asked for a driver.  "Don't show drivers not available with this system was checked."


                  One was for the "mega RAID" of which I understand, from past readings, the mega RAID is for those with the upgrade RAID 5 key, thusly resulting in my using the other available driver.  I was suspecting that both would work but we shall see if I can manage the RAID arrays through the web console once the OS is loaded later in the day.


                  Thanks David_Intel.  I'll get back to the thread tonight with the result. 

                  • 6. Re: s5000sva, web console, can't find server, Small Business Server 2008

                    I am glad to read that the process is going well. I will be looking forward to see your new post with the resolution of the case.

                    • 7. Re: s5000sva, web console, can't find server, Small Business Server 2008

                      That did the trick.  Now running RAID 10 with one OS drive as the board ports and lack of additional keyed hardware for RAID 5 prohibit me from RAIDing the OS drive.  Did get the replacement 3ware card; however, in production, it is my opinion that the intel RAID will suffice as long as we are imaging our OS backups with programs installed etc.  Only problem may be our POS database I set up using thunderbird which stores the database backups and conf data under program files.  May need to make SURE we are imaging that drive daily, or set up the 3ware card when time as it would allow me to RAID 5 = a mirrored set for the OS and program data.  With the 3ware, it states "standalone" drive where intel is more vague, to me, at least, for any course I studied taught me that a RAID 0 consisted of at least 2 drives. 


                      Thank you David, for your help!