14 Replies Latest reply on Apr 30, 2015 5:47 AM by wojci

    wifi ad-hoc

    eddyson

      Hi,

       

      Does it possible to configure a wifi ad-hoc network on the edison?

       

      regard

        • 1. Re: wifi ad-hoc
          Intel_Alvarado

          Hi eddyson,

           

          I’ve not tried to set up ad hoc on the Edison yet but I believe the procedure to do so might be similar to that of the Galileo. Take a look at this post https://communities.intel.com/message/237865#237865 and the links other users posted.

           

          Regards

          Sergio

          • 2. Re: wifi ad-hoc
            Intel_Alvarado

            Was the previous suggestion helpful? If you still need assistance please reply with your questions.

            Regards

            Sergio

            • 3. Re: wifi ad-hoc
              eddyson

              Thanks a lot!

               

              Your proposition is not a solution.

              Finally, I wonder if I made the right choice with Intel-Edison for my IoT projects?

               

              Best regards

              • 4. Re: wifi ad-hoc
                mhahn

                what exactly do you need to accomplish?

                I am not sure whether "WiFi direct" or a WiFi ad-hoc network would work but maybe you don't really require it?

                I haven't tried on Edison yet but I guess you could for instance use Edison as an access point + run a DHCP server such that other components could connect to it.

                I know that's not an ad-hoc network but maybe it would be fine for what you're up for?

                • 5. Re: wifi ad-hoc
                  David_J_Hunt

                  Yes, it is possible.

                   

                  I'm using ubilinux (Debian).

                   

                  I edited /etc/network/interface, and entered the following for wlan0:

                   

                  auto wlan0

                  iface wlan0 inet static

                      address 192.168.42.1

                      netmask 255.255.255.0

                      wireless-essid edison

                      wireless-mode ad-hoc

                  Note that /etc/network/interfaces is not available in Yocto, so I'm not sure how you'd do it there, but it should be possible, although I hate saying "it should be possible" without actually testing it.

                   

                  Once the above is in /etc/network/interface, I did "ifup wlan0"

                  and I could then use 'iwconfig' to confirm that the Edison was indeed in ad-hoc mode, I could see

                   

                  root@ubilinux:~# iwconfig  

                  wlan0 IEEE 802.11abgn  ESSID:"edison"

                       Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: Not-Associated

                       Tx-Power=31 dBm

                       Retry  long limit:7   RTS thr:off   Fragment thr:off

                       Encryption key:off

                       Power Management:on

                  And I could then connect to it with my iPhone. I didn't have time to pass traffic, but I think that demonstrates it can be done.

                   

                  Rgds,

                  Dave.

                  1 of 1 people found this helpful
                  • 6. Re: wifi ad-hoc
                    deium

                    I agree with mhahn, can you share what you're trying to accomplish.  I'll try to help you figure out a how.

                    @David_J_Hunt, I am going to see if I can get some steps for how-to via the tools on a bare Yocto image.

                    • 7. Re: wifi ad-hoc
                      ksam917

                      Dave,

                      I want to configure the ad hoc network using EDISON board. Is EDISON board support for the ad hoc? what is the difference between yocto and ubilinux? 

                       

                      ksam

                      • 8. Re: wifi ad-hoc
                        Intel_Alvarado

                        Hi,

                         

                        Ad-hoc is not supported in the current release. We will look into and see if it will be supported in the future release.

                         

                        Regards

                        Sergio

                        • 9. Re: wifi ad-hoc
                          fwwsc

                          I've been trying to do an ad-hoc network too, and when I ran these commands on the Edison:

                           

                          ifconfig wlan0 up

                          iwconfig wlan0 mode ad-hoc

                          iwconfig wlan0 essid "abc"

                          ifconfig wlan0 192.168.1.1 netmask 255.255.255.0


                          I was able to see the "abc" network on my mac and connect to it.


                          Screen Shot 2015-02-16 at 3.00.45 PM copy.png


                          My mac & phone have no problem connecting to it, but I have a second edison and I can't connect them between themselves.

                          I'm not sure if edison # 2 should also be in ad-hoc mode or just one?

                          Maybe someone can shine some light on this!

                          • 10. Re: wifi ad-hoc
                            Kurdman

                            To fwwsc's question / point - is mesh networking possible with the Edison?

                            • 11. Re: wifi ad-hoc
                              wojci

                              I'm looking at ad-hoc networking with edisons as well.

                               

                              Did you have any success with making the edisons talk to each other using ad-hoc wifi?

                               

                              I had limited success as it looks like two edisons can communicate, but using more than two makes the ad-hoc network stop working. Also I have issues with broadcasts not working - I need this for DHCP to work. Setting up the yocto linux software installed on my edisons for adhoc networking (which I hope to use for a mesh network) was something of a challenge for me. If anyone is interested I could write a short howto.

                              • 12. Re: wifi ad-hoc
                                Rockwood

                                Hi,

                                 

                                Yes I am certainly interested in connecting edisons. Please inform us. Thanks.

                                • 13. Re: wifi ad-hoc
                                  Intel_Alvarado

                                  Hi,

                                   

                                  Have you already seen this document Intel® Edison Products — Intel® Edison Wi-Fi User Guide . Section 4.2.4 has some relevant information on ad hoc.

                                   

                                  Sergio

                                  • 14. Re: wifi ad-hoc
                                    wojci

                                    I managed to setup simple ad-hoc networking on 3 edisons. I use no encryption for the wifi adhoc network.

                                    I used ahcpd (AHCP — the Ad-Hoc Configuration Protocol) to assign IP addresses to the members of the mesh and olsrd (OLSR.org Wiki) to setup routing. I tested the routing by adding a firewall rule making it impossible to ping one host directly and noticed that olsrd added a route so that packets from the blocked host will go indirectly.

                                    So it looks like I have a small working mesh.

                                     

                                    I made a custom layer with the software that I use so let me know if anyone wants ahcpd/olsrd recipes.

                                     

                                    My attempts to use wpa/wpa2 for the adhoc network failed. This is also not covered in the Intel WiFi document.