2 Replies Latest reply on Oct 21, 2014 1:29 PM by garbel

    Problems installing the Serial Port Driver on Windows7 for Galileo Gen2

    garbel

      I just got my Galileo Gen2 board today and I'm having problems installing the Gadget Serial v4.2 Driver as detailed in the Gettting Started Instructions:  Galileo Getting Started - Windows

       

      I searched here on the forum and I tried just about everything in similar posts so I wanted to file my own.  Sorry if I missed the key one that also solves my problem.

       

      I did all the obvious thing like rebooting the board and PC.   I don't have any kind of sd card in the board.   This board is right out of the box.

       

      After installing the downloaded Arduino software (arduino-windows-1.0.4.7z),  I start it up (Step 2 - Download Galileo Arduino IDE in the Gettting Started).

       

      As detailed in Step 3,  I open Device Manager but I don't see an  "Others" category where the Gadge Serial V4.2 driver is supposed to be.   I make sure the board is connected and powered up.  I tried two different USB cables and I tried a USB on the front and back of the PC  (Dell Optiplex 980).

       

      Per one of the other issues on the forum,  I tried to manual install the driver by going to C:\arduino-1.5.3-Intel.1.0.4\hardware\arduino\x86\tools and right-mouse clicking on the linux-cdc-acm.inf file and selecting  "Install" from the menu.  Doesn't appear this driver supports this type of installation:

      2014-10-20_15-59-35.png

       

      If I go back to the Device Manager and do a "Scan for Hardware Changes",  it has a "PCI Serial Port" listed in the Others category.

       

      2014-10-20_16-04-15.png

       

      This doesn't seem to be associated with the Galileo Board since I see this if I unplug the USB cable from the PC and do the scan again. 

       

      Not sure how to proceed at this point and would appreciate any pointers.