3 Replies Latest reply on Oct 16, 2014 7:13 AM by allan_intel

    Cannot disable game fullscreen scaling (Intel HD 4600)

    supYall

      The problem:

      When I start a fullscreen application in lower than native screen resolution, the image is automatically scaled (and stretched) to fill the screen.

      Besides the obvious display problem, this seems to come with considerable amount of lag added. (At least the mouse movement feels very sluggish)

       

      CPU: i5-4690K

      Intel HD Graphics 4600

      Windows 7 Home Premium 64-bit

       

      Monitor: Samsung SyncMaster 2032BW

      1680x1050 (16:10)

       

      To be precise, the tested game is GTA 3 (DirectX) at 1024x768. (But it happens in any such game)

      I want it to be displayed pixel accurate with black bars all around the game.

      (GTA 3 supports my native resolution, but that is besides the point. (Actually, it isn't "properly" supported, as it is still stretched.))

       

      I have read threads where people want the opposite, so why is mine always scaled and stretched?

       

      Driver Version: 10.18.10.3907

      DirectX: 11.0

       

      The only scaling options I have are:

      Display -> Scaling

      Video -> Image Scaling

       

      Neither of them seems to be doing what I want.

       

      If I didn't know better, I'd think my monitor just stretches the image. The monitor reports 1024x768 as the resolution (while it is stretched to fullscreen).

      But under Windows XP with a Nvidia GeForce GPU I could select "No Scaling" in their driver software and the result was the desired black bars around the game.

       

      Please help?

       

      Regards