8 Replies Latest reply on Jun 8, 2017 3:33 AM by scerazy

    I218-V Wake On Lan broken with Fastboot - Bug

    Stasis

      Hi all

       

      Currently with the all available versions of the Windows 8.1 x64 I218-V you cannot use Wake On Lan if you have fastboot enabled, which is extremely painful.

       

      Specs of system:

      Operating System: Windows 8.1 Pro 64-bit

      CPU: Intel Pentium G3420

      RAM: 8.00GB DDR3 (9-9-9-27)

      Motherboard: ASUS Z97M-PLUS

      HDD: 500gb WD Black

       

      This is a media pc, which really would make use of fastboot.

       

      I've tried the drivers, all versions available, from the ASUS site:

      Intel LAN Driver V12.11.96.1

      Intel LAN Driver V19.0.27.0


      This new driver from Intel site:

      PROWinx64.exe 19.3

       

      BIOS has correct settings to allow wake on lan.

       

      Every single kind of power related setting imaginable to disable management on ALL devices, full power mode ahead. No joy.

       

      No matter what options you use this horrendous set of drivers does not allow wake on lan with fast boot enabled, unlike every single realtek nic based mobo i've ever used.

       

      I doubt that it will be fixed, or if Intel engineers even read these forums. But here's to hoping...

       

      While it works without fast boot enabled, this is not a fixed. Merely a bandaid to the dodgy driver.

        • 1. Re: I218-V Wake On Lan broken with Fastboot - Bug
          sage99

          Hi Stasis, not sure if you've already tried this combination:

          1. fast boot - enabled

          2. network stack driver support - enabled (under the "Boot" option of Asus Z97M-Plus)

           

          hope this helps.

           

          regards,

          Vince

          • 2. Re: I218-V Wake On Lan broken with Fastboot - Bug
            Stasis

            Thanks for the response, I should have mentioned in my first post that I also tried doing what you've suggested and this does not work.

             

            To clarify:

             

            Enabling stack driver support under boot options and other options in BIOS does not resolve this issue.

            • 3. Re: I218-V Wake On Lan broken with Fastboot - Bug
              sage99

              thanks for the update, have you tried using a discreet network adapter to further isolate the issue? how'd you perform the magic packet thru magic packet?

              • 4. Re: I218-V Wake On Lan broken with Fastboot - Bug
                Stasis

                Sent magic packet using router tool and through an android function I use daily which works fine with fastboot off, and works fine with fast boot on on every other device I have (this is the only Intel NIC I've unfortunately been stuck with)

                 

                I'm considering purchasing another NIC to bypass this issue, a bit ridiculous when Intel should resolve with a driver update.

                • 5. Re: I218-V Wake On Lan broken with Fastboot - Bug
                  Stasis

                  Bump

                   

                  Any intel engineers check these forums?

                  • 6. Re: I218-V Wake On Lan broken with Fastboot - Bug
                    rosiao

                    Hi Stasis,

                     

                    Sorry for the delay.  I got this from our engineers:

                     

                    Instructions for Enabling WOL in FastStartup

                    **Currently Supported On: Intel® i217/i218 w/Clarkville SW6 PV Driver**

                     

                    Following are the changes required, for Intel® PHY/LOM products, to support WOL in Fast Startup:

                    • Enable LOM driver by setting registry “WakeOnFastStartup" to 1

                    • View “ReadMe-WakeOnFastStartup.txt” to use theWakeOnFastStartup.bat file correctly

                    • Add a write in BIOS in IO space of ACPI, register GPE0a_EN in (Base address* + 0x28), set bit 13, PME_B0 Enable

                    **IO space base address of ACPI can be found in PCI device 31, Function 0, offset 0x40.

                     

                    Additional Notes:

                    • After Enabling LOM driver by setting registry
                    “WakeOnFastStartup" to 1, the BIOS will set this bit whenever the system goes to S5 Fast Startup.

                    • System does not need to check for driver WOL setting because the driver will always configure WOL based on the above registry change

                    • If the user disables the WOL capability in the menu, no issues should occur since the driver won’t configure any filter in the PHY.

                    • An external power supply to the LAN is required on FastStartup if WOL is enabled.

                     

                    Thanks,

                    Rich

                    • 7. Re: I218-V Wake On Lan broken with Fastboot - Bug
                      theduck01

                      Hi,

                       

                      I have a very similar problem and am struggling implementing with rosiao's answer.

                       

                      Specs of system:

                      Operating System: Windows 10 Pro 64-bit

                      CPU: Intel Core i5

                      RAM: 8.00GB DDR3

                      Motherboard: ASUS H97M-PLUS

                      SSD: INTEL SSDSC2CW180A

                       

                      This is a office pc which needs to WOL for its nightly remote backup and I would really like it to "fast start-up".

                       

                      I have the most up to date Intel LAN Driver V12.13.17.4


                      With "fast start-up" off WOL works perfectly. With "fast start-up" on WOL refuses to work.

                       

                      I have tried to follow these instructions:

                       

                      • Enable LOM driver by setting registry “WakeOnFastStartup" to 1

                      • View “ReadMe-WakeOnFastStartup.txt” to use theWakeOnFastStartup.bat file correctly

                      • Add a write in BIOS in IO space of ACPI, register GPE0a_EN in (Base address* + 0x28), set bit 13, PME_B0 Enable

                      **IO space base address of ACPI can be found in PCI device 31, Function 0, offset 0x40.

                       

                      I have successfully setup the registry, but can not find “ReadMe-WakeOnFastStartup.txt” on the internet and do not understand how to "Add a write in BIOS in IO space of ACPI, register GPE0a_EN in (Base address* + 0x28), set bit 13, PME_B0 Enable". However, if I have understood "After Enabling LOM driver by setting registry “WakeOnFastStartup" to 1, the BIOS will set this bit whenever the system goes to S5 Fast Startup." correctly a reboot will cover the rest of the instructions.


                      I would be grateful for some help with this issue.


                      Many thanks,


                      theduck01

                      • 8. Re: I218-V Wake On Lan broken with Fastboot - Bug
                        scerazy

                        Same problem with

                         

                        Intel(R) Ethernet Connection I219-LM

                         

                        on Gigabyte Brix GB-BKi5(H)A-7200

                         

                        Using driver 12.15.23.9

                         

                        Intel(R) Ethernet Flash Firmware Utility

                        BootUtil version 1.6.39.1

                        Copyright (C) 2003-2017 Intel Corporation

                         

                        Type BootUtil -? for help

                         

                        Port Network Address Location Series  WOL Flash Firmware                Version

                        ==== =============== ======== ======= === ============================= =======

                          1   1C1B0DBC22F7     0:31.6 Gigabit N/A FLASH Not Present

                         

                        Of course I read https://www.intel.co.uk/content/www/uk/en/support/network-and-i-o/ethernet-products/000005793.html

                         

                        I have set WakeOnFastStartup to "1"  (enabled)

                         

                        Brix BIOS F5 has very limited options

                         

                        With Fast Startup DISABLED WoL works as expected

                         

                        If I enable Fast Startup there is light on the card stays at Power Off, but WoL does NOT work!

                         

                        So the only option is to disable Fast Startup (not ideal)

                         

                        Anybody has any constructive ideas?

                         

                        Seb