5 Replies Latest reply on Oct 26, 2015 3:13 PM by Ozmo

    Does Edison Arduino IDE support SoftwareSerial library?

    Alex_R

      Hi,

       

      I downloaded arduino-1.5.3-Intel.1.0.3. I tried co compile an Arduino program that uses SoftwareSerial library, and I get an error:

      fatal error: SoftwareSerial.h: No such file or directory. compilation terminated. My board is set to Intel Edison.

       

      If I open one of the examples from SoftwareSerial library that comes with Arduino Edison, I get the same error.

      I noticed that SoftwareSerial library was changed in the Arduino Edison distribution, and source files moved into src and arch. I tried using the standard SoftwareSerial library that didn't compile. I tried moving files away from the src and arch into the root directory of the library, and I got a different error, in SoftwareSerial.cpp: LINUX_SOFTSERIAL_TTY_OBJ not defined.

      When I looked into SoftwareSerial.cpp, I found this comment:

         // If LINUX_SOFTSERIAL_TTY_OBJ is not defined, SoftwareSerial is unsupported on this platform variant

       

      So my question is: Is SoftwareSerial supported in Arduino Edison?