5 Replies Latest reply on Oct 17, 2014 10:37 AM by sylvia_intel

    Intel NUC DN2820FYKH SATA Drive not showing in BIOS

    Maxwell-Alexander

      Hi guys,

       

      I'm hoping you can help.

      On Friday I purchased an Intel NUC DN2820FYKH. Installed the correct RAM and HDD and windows 8.1 through USB. The system installed the OS and booted normally. However, when I shutdown the mini-pc and later turned it back on, it would not recognise the SATA drive.

       

      I assumed something must have gone wrong so after a bit of playing around, I removed it, formatted it in another machine and repeated the process. Eventually I re-installed windows 8. To check, I shut down the computer immediately, and the same problem occurred upon booting.

       

      The initial startup screen (showing F2 for setup) hangs when the drive is plugged in but the bios shows that no internal SATA drive is present, I tried mounting the drive in an external caddy and connecting it by USB and the computer was able to see it again.

       

      On Friday I updated to the latest BIOS (fy0039). I rolled the BIOS back to (fy0015) and tried every update since then without luck.

       

      I don't think its a hardware fault as a format fixed it until I booted into windows the first time. Before I booted into windows I was having a bit of trouble finding the right installer and the drive was showing up fine. It seems that it's only once I've booted into windows that the drive vanishes on shutdown.

       

      I am using a trial copy of 8.1 Enterprise from MS website.

      Please note that I have also posted this question on the Eight Forums (Intel NUC DN2820 SATA Drive not showing in BIOS) but thought I would post here too as this is an Intel product.

       

      Does anyone have any ideas?

       

      Max