3 Replies Latest reply on Oct 6, 2014 12:01 PM by sylvia_intel

    DN2820FYHK

    clarkie42

      Just purchased the above along with 4gb 1.35v of ram and a 64gb ssd.I have put everything together but im not getting any bios screen just blank.Im trying to install openelec to run it as a htpc.Anyone got any ideas whats wrong?

        • 1. Re: DN2820FYHK
          dougho

          I am not from Intel, but there seem to be two common problems.  One is are you perhaps trying to hook to a computer monitor rather than an HDTV?  When my NUC was delivered it would not display on computer monitor, but would display on 1080 HDTV.  After updating the BIOS (which involved using a non-Microsoft keyboard), I was able to display on both a computer display and an HDTV (although the display may be forced to 1024x768@60Hz in center of screen).

          The other common problem is that just saying 4GB 1.35v is not enough detail.  The 1.35v needs to be specified in the SPD using JEDEC standard (probably is), the chips need to be of a certain "density" (not sure but this probably means only 4 or 8 chips per side not 16 chips per side) and the speed of the memory probably cannot exceed 1600.  Incorrect memory may produce some blinking pattern on the power light (again, not sure about that detail).

          • 2. Re: DN2820FYHK
            clarkie42

            No using it on a HDTV and I have tried 2 HDMI cables.There is no power light blinking and I have tried a different ram card that works in my i3 nuc.

            • 3. Re: DN2820FYHK
              sylvia_intel

              Hello Clarkie42, thanks for joining the NUC community.

              I would recommend you to perform a BIOS update using the recovery procedure.

              http://www.intel.com/support/motherboards/desktop/sb/CS-023360.htm

               

               

              If the behavior persisted please contact Intel support for warranty options at:

               

              Online warranty: New Service Request

               

              Chat support: Contact Support

               

              Regards,