10 Replies Latest reply on Oct 28, 2014 1:51 PM by mjstanis

    [SOLVED] BSP 1.0.1 fails on OpenCV 2.4.9 during build

    mjstanis

      Hi everyone,

       

      I'm using Ubuntu 12.06 with the latest BSP suggested in the instructions online (seems to be 1.0.1).  I modified my OpenCV 2.4.3 recipes to install 2.4.9 as per the instructions here:

       

      OpenCV Galileo link broken. Please push fix to main repo


      I nearly reached the end of my build of the image-full-galileo image, when I ran into an error, which is captured in the log.do_configure output below:

       

      DEBUG: Executing python function sysroot_cleansstate

      DEBUG: Python function sysroot_cleansstate finished

      DEBUG: SITE files ['endian-little', 'bit-32', 'ix86-common', 'common-linux', 'common-uclibc', 'i586-linux-uclibc', 'common']

      DEBUG: Executing shell function autotools_preconfigure

      DEBUG: Shell function autotools_preconfigure finished

      DEBUG: Executing shell function do_configure

      CMake Error: The source directory "/home/matt/meta-clanton_v1.0.1/yocto_build/tmp/work/i586-poky-linux-uclibc/opencv/2.4.3-r2/OpenCV-2.4.9" does not appear to contain CMakeLists.txt.

      Specify --help for usage, or press the help button on the CMake GUI.

      ERROR: Function failed: do_configure (see /home/matt/meta-clanton_v1.0.1/yocto_build/tmp/work/i586-poky-linux-uclibc/opencv/2.4.3-r2/temp/log.do_configure.22412 for further information)

       

      I took at the 'OpenCV-2.4.9' directory and it is completely empty.  Installing the latest version of Cmake didn't seem to help.

       

      What can I do to resolve this issue?

       

      Thanks!

      Matt