3 Replies Latest reply on Oct 3, 2014 7:15 AM by allan_intel

    Aspect ratio (keep proportions) issue, Intel Core i5 integrated graphics


      Hello there!


      I've bought some new PC recently, and currently have problems setting up graphics driver.


      The system works pretty well @ native 1920*1080 widescreen, however whenever I switch it to non-16:9 resolution, it tries to upscale the image, breaking aspect ratio in the process. Say, any 640:480 (4:3) becomes wide and disproportional. What I want, is to always keep proportions regardless of resolution.


      So, I checked the utility that came along with graphics driver and couldnt find there such an option (resolution 1920*1080). Then I switched desktop's resolution to 1280*1024 (5:4) and indeed, there it was (lightened "Сохранить пропорции" in Russian is "Keep proportions" or kind of). The problem is, this setting is reset every time resolution is changed, and the default one is "make everything look fat and weird on your big widescreen", which is not really smart, or I'd say, Intelligent, on the part of Intel .


      Now here is how it works for me: I boot the PC into native desktop resolution 1920*1080. Run any non-16:9 game, like fallout2 or starcraft1 (2d engine @ 640*480 and can't be changed without violationg eula or anticheat system, but that's not the point), it scales to all screen. I change it to "keep proportions" via hot-keys, and everything is fine until I decide to alt-tab back to desktop and go back, because it first changes to 1920*1080, and then back to 640*480 with proportions broken again. Basically, I have to ctrl-alt-f11 three times every time I alt-tab.


      Before that, I've been using ATI graphics for 12 years (from radeon 9xxx to HD6xxx) and there always been similar option which worked and didn't reset. Is this a driver, or utility, or maybe monitor issue? 3 screenshots are added with technical information.


      I am sorry if my English isn't good enough, but hopefully someone can understand what's up and suggest me a solution. Thank you.