1 2 3 Previous Next 35 Replies Latest reply on Sep 16, 2016 2:04 AM by mhahn

    SSH to my edison?

    AnthonyWebb

      I did a netstat -an and found that port 22 was open, wondering if I can SSH to the edison?  Would be really handy to not have to be tethered to manage the thing.  Anyone have any other info on this?

        • 1. Re: SSH to my edison?
          AnthonyWebb

          I found that once I had wifi working I was able to ssh to the IP of the edison without any hiccups.  Nice.

          • 2. Re: SSH to my edison?
            Sulamita

            I just updated my Edison board to the latest image and I can't access via ssh. I tried to restart sshd but has not worked. How can I check what is wrong?

            • 3. Re: SSH to my edison?
              intel_dan

              Can you access the Edison via the serial console? If you watch the output on the serial console while the board is booting, you may be able to see some errors.

              • 4. Re: SSH to my edison?
                Sulamita

                Yes, I can. I found out what is the problem. The latest image won't start ssh if both wifi and the password are not set. I didn't have the password. It's working now.

                • 5. Re: SSH to my edison?
                  rui.araujo

                  You have to edit the systemd service to allow shh without a password.

                  vi /lib/systemd/system/sshd.socket

                  In this file, comment out the line BindToDevice=usb0 with a #

                   

                  Then reboot and you should be able to ssh without a password.

                  • 6. Re: SSH to my edison?
                    AnthonyWebb

                    I updated and lost SSH as well.  Are you saying you set a password for root?  Sulamita Can you detail how you set the password?

                    • 7. Re: SSH to my edison?
                      AnthonyWebb

                      Here is what I tried.  I logged in as root (no password) and from the command prompt typed "passwd" this walked me through settings up a password, which I assume was for the root user.  Next I rebooted.  This time when I entered a username of "root" it asked me for a password, which I entered and logged in.

                       

                      Yet still, I am unable to SSH from another computer:

                       

                      $ ssh root@192.168.11.5

                      ssh: connect to host 192.168.11.5 port 22: Connection refused

                      • 8. Re: SSH to my edison?
                        rui.araujo

                        Try editing the systemd service. I am sure it will work whether you have a password or not.

                        • 9. Re: SSH to my edison?
                          Sulamita

                          AnthonyWeb: I used the command configure_edison --setup. This configures the wifi, the password and there is something in there that enables the sshd server.

                           

                          Rui: The password requirement was enabled due security requests, otherwise anyone can access any Edison board anywhere. You can of course hack your board to bypass it, but there should be a warning notice that's at your own risk. It's one thing at the security of your home lan, another is a product in the market.

                          1 of 1 people found this helpful
                          • 10. Re: SSH to my edison?
                            szirin

                            The factory software image for Edison has SSH access enabled only via the USB Gadget network interface (192.168.2.15).   Configuring the board with 'configure_edison --setup' prompts for a root password, configures Wi-Fi, and enables SSH access over Wi-Fi.

                             

                            I recommend that you leave the root password set if you're joining your Edison to a shared Wi-Fi network.  You can avoid entering the root password each time you connect via SSH by setting up public key authentication between the systems you trust and your Edison board.

                            1 of 1 people found this helpful
                            • 11. Re: SSH to my edison?
                              rubidium

                              After trying for hours to SSH into Edison wirelessly, I finally discovered that I had to do the following:

                               

                              ifconfig usb0 down

                              ifconfig wlan0 down

                              ifconfig wlan0 up

                               

                              Apparently usb0 on 192,168.x.15 and wlan0 on 192.168.x.y can't be up together. Unfortunately, I have yet to discover how to make this permanent, so I end up going through this exercise after every reboot.

                              Jim

                              • 12. Re: SSH to my edison?
                                intel_dan

                                I know there is config file to change the default ip range of the usb0 ethernet interface. I will see if I can find the exact config file and post a reply.

                                • 13. Re: SSH to my edison?
                                  intel_dan

                                  Try editing

                                   

                                  /etc/systemd/system/basic.target.wants/network-gadget-init.service

                                   

                                  and changing both lines that have 192.168.2.15 to something in a different ip range

                                  1 of 1 people found this helpful
                                  • 14. Re: SSH to my edison?
                                    rubidium

                                    Yes, that's it!  Changed both occurrences of 192.168.2.15 to 192.168.99.15, rebooted, and able to SSH through wlan0!! woot!!

                                    Thanks,

                                    Jim

                                    1 2 3 Previous Next