3 Replies Latest reply on Oct 4, 2014 5:45 PM by WayneB

    Arduino IDE error compiling

    onehorse

      I am trying to follow the getting started tutorial for Edison on a Win 32 System 7 laptop. After I downloaded the Arduino IDE and unzipped it with 7Zip, I tried to compile the blink program and encounteredd this error message in verbose mode:

       

      Arduino: 1.5.3-Intel.1.0.3 (Windows 7), Board: "Intel® Edison" C:\Users\Pesky Products\Desktop\arduino-windows-1.0.3\arduino-1.5.3-Intel.1.0.3/hardware/tools/edison/sysroots/i686-pokysdk-mingw32/usr/bin/i586-poky-linux/i586-poky-linux-g++ -m32 -march=i586 --sysroot=C:\Users\Pesky Products\Desktop\arduino-windows-1.0.3\arduino-1.5.3-Intel.1.0.3/hardware/tools/edison/sysroots/core2-32-poky-linux -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -MMD -D__ARDUINO_X86__ -march=i686 -m32 -DARDUINO=153 -IC:\Users\Pesky Products\Desktop\arduino-windows-1.0.3\arduino-1.5.3-Intel.1.0.3\hardware\arduino\edison\cores\arduino -IC:\Users\Pesky Products\Desktop\arduino-windows-1.0.3\arduino-1.5.3-Intel.1.0.3\hardware\arduino\edison\variants\edison_fab_c C:\Users\PESKYP~1\AppData\Local\Temp\build5436329423253845910.tmp\Blink.cpp -o C:\Users\PESKYP~1\AppData\Local\Temp\build5436329423253845910.tmp\Blink.cpp.o i586-poky-linux-g++: error: Products\Desktop\arduino-windows-1.0.3\arduino-1.5.3-Intel.1.0.3/hardware/tools/edison/sysroots/core2-32-poky-linux: No such file or directory

       

       

      The IDE is in a folder on my Desktop and is separate from the usual Arduino IDE I have been using. I have Edison chosen as the board and COM 19 which is one of the ports assigned to the Edison.

       

      What could I be doing wrong?

        • 1. Re: Arduino IDE error compiling
          StevenH

          I don't know if this will help you or not, I was having a similar problem and found your post while looking for a solution.  I found a solution just testing a theory, it ended up being that the compiler can't handle being in directories that contain a space anywhere in the parent path.  Try putting the edison arduino ide folder directly on a root drive (C:\ for example) and make sure it is named without a space in it.  Example C:\Edison_Arduino_IDE\

          • 2. Re: Arduino IDE error compiling
            onehorse

            Excellent! Yes, now I can compile and, I think load the program. But the Edison is not blinking. I have two COM ports that appear when I plug both mini USB cables into the Edison mini breakout board. I tried them both. Only one give a transfer complete message, but shouldn't the Edison be blinking?

            • 3. Re: Arduino IDE error compiling
              WayneB

              Excellent! Thank You so much, StevenH and onehorse. I was about to pull out the little hair that I've got. I had the Arduino IDE installed in "F:\Intel Edison". Changed it to "F:\Edison" and it works.

              Wayne