9 Replies Latest reply on Sep 30, 2014 5:16 PM by Stevie67

    OSX linux image updating issues

    ril3y

      I have been working on getting my image updated for my Edison boards.  I have a smaller dev board model and a larger arduino model.  I have followed the instructions copied over the files into the Edison drive that shows up but it seems that I am getting read errors on random different files after I do the reboot ota step.  Which kicks it out of updating and then just boots the current version of linux.

       

      So I redownloaded the image file and tried again on both devices.  Still no luck.  I then thought I would just do a wifi update.  However it looks like my version of configure_edison python script does not have the needed command flags to do so.  I assume my version is quite old?

       

      I am not sure which is easier but I think just getting an up to date configure_edison python script would solve my updating issues pretty quickly.   Please let me know if you have heard of anyone else having such issues and if they got them fixed

       

      Thanks,

       

      ril3y

        • 1. Re: OSX linux image updating issues
          JPMontero_Intel

          Hi ril3y,

           

          No, I haven’t heard about this. Have you already tried re-flashing your board?

           

          Regards,
            JPMontero_Intel

          • 2. Re: OSX linux image updating issues
            szirin

            Make sure that you properly eject the 'Edison' drive after copying the entire unzipped contents of the new image.  This will ensure that all buffered data has been transferred before the 'reboot ota' resets the board.

             

            Answers to these questions may help others help you if you're still having trouble:

            1. What version image is currently loaded on your Edison board?   The command 'cat /etc/version' will display the details.
            2. What new image are you trying to install?   If you downloaded the new image from this Community site the name of the zip file will identify the version.
            • 3. Re: OSX linux image updating issues
              ril3y

              My version is:  edison-weekly_build_56_2014-08-20_15-54-05

              and the url is:

              http://downloadmirror.intel.com/24271/eng/edison-image-ww36-14.zip


              Which of course was provided from: https://communities.intel.com/docs/DOC-23242


              I have used the proper eject operation as well every time.


              I hope that helps.  If there a another image to flash please let me know and I will try that one out.


              ril3y


              • 4. Re: OSX linux image updating issues
                ril3y

                JPMonteiro  I am not exactly sure what you mean if I have tried to reflash it?  Thats what I am saying I am having issues with.  Unless I am completely missing the mark

                • 5. Re: OSX linux image updating issues
                  raminf

                  I finally got it working (with the smaller connector board) but it took a few tries on Mac OS (Yosemite). Here are a few issues to look out for:

                   

                  - The cable connections make a difference. I had a bunch of micro-USB cables around. Plugged two of them in but noticed one of them not seating straight. Thought nothing of it, but started getting repeated gray-screen system crashes on the Mac every time I unplugged the USB cable. Changed both cables with ones that looked like they fit better (went straight in, seated well) and the crashes went away.

                   

                  - When I plugged the two wires directly into a Macbook Air I could see the Edison mounted as a device, but could not connect to it via the 'screen' command. But if I connected the Edison power cable (the one closest to the 2-pin jumper) to an external power supply or a powered USB 3 hub, I couldn't mount the Edison but could login via screen. So I ended up copying all the files over with two cables connected to the Mac, shutting down BOTH the Mac and the Edison, plugging the Edison power to a hub, then restarting everything. Once I got in with 'screen' I could do a 'reboot ota' and it all worked fine from there on.

                   

                  - The documentation on the Edison site with the screen caps is showing the newest version of the software, so some of the 'configure_edison' commands aren't there on the shipping version. One you load up the new version, however, everything looks the same as the screen tutorials. Getting there, though, is a pain.

                   

                  Now I run the Edison with the power cable NOT connected to the Mac and it works fine. To transfer big files to the Edison instead of using the mounted storage trick I copy to Dropbox and use 'curl' to get it from the network.

                   

                  Ok, HTH.

                  • 6. Re: OSX linux image updating issues
                    ril3y

                    This is the exact error message that pops up right after

                    reboot ota

                    is issued.

                    fatload mmc 0:9 0x6400000 edison-image-edison.ext4;

                    reading edison-image-edison.ext4

                    ** Unable to read file edison-image-edison.ext4 **

                    Saving Environment to MMC...

                    Writing to MMC(0)... done

                    resetting ...

                    • 7. Re: OSX linux image updating issues
                      ril3y

                      raminf

                       

                      I am not quite sure that your issues are the same as mine?  I could mount and copy files np.  I could screen np.  The only thing that I had issues with is the update saying invalid files like the message above.  Are you saying you had this issue as well and you fixed it by doing what you said?

                      • 8. Re: OSX linux image updating issues
                        ril3y

                        Ok guys I found out the problem.  It has to do with the unzip function on OSX 10.5  My buddy has 10.4 and it works fine.  So I had to unzip the image at the command line unzip file.zip /Volumes/Edison

                         

                        Then reboot ota worked just fine.  Sorry guys but I am sure others will have this problem.

                         

                        ril3y

                        • 9. Re: OSX linux image updating issues
                          Stevie67

                          Thanks ril3y!!! I indeed had the same problem, unzip it from the commandline helped. Then also the web page was displayed properly.