3 Replies Latest reply on Sep 22, 2014 11:02 AM by allan_intel

    Intel DN2820FYKH will not boot!

    keiron99

      I got a DN28820FYKH this week, with the intention of installing openelec an uding purely for xbmc.

       

      However, I've not been able to get it to do anything.

       

      Installed the RAM OK. I intend to use a USB rather than SSD. It's simply for XBMC, so I plan using Openelec.

       

      However, as soon as it's plugged in to the monitor, I get the NUC splash screen but it will not respond to any key presses (I have tried two keyboards).

       

      I created a bootable USB, but it tells me there is no bootable device detected. (I tried three different sticks, and various methods of creating a bootable stick).

       

      So, I assumed there's a problem with the bios. I follow the Intel instructions to recover the bios and get the message "bios security jumper removed - Suppress this menu until the bios security jumper is replaced - Clear bios user and supervisor passwords".

       

      I am completely stuck now. Any help would be appreciated, although I do feel I have tried everything!

        • 1. Re: Intel DN2820FYKH will not boot!
          dougho

          I am not from Intel, but you may have received incorrect info about BIOS jumper.  I do not recall details at this moment, but the instructions for NUC jumper are typically different from those of all previous/regular Intel motherboards.  Regarding the two keyboards you tried, were both of them Microsoft?  When I received my NUC, I was in similar situation to you because all I had were Microsoft keyboards.  When I attached a non-Microsoft keyboard, I was able to use the keyboard.  Then I updated BIOS, and after that I was able to use Microsoft keyboard.  And what you may need to do for booting is to make sure that legacy boot is enabled (defaults may depend on the BIOS version).

          • 2. Re: Intel DN2820FYKH will not boot!
            keiron99

            Thanks for replying. I'm quite sure I am following the correct instructions about the jumper. There's a page dedicated to the NUC here

             

            Neither of the keyboard are Microsoft.

             

            I simply can't do anything with it, it is as though it was "bricked" right out of the box. Very disappointing.

            • 3. Re: Intel DN2820FYKH will not boot!
              allan_intel

              Thanks for joining the NUC community.

              If you already performed BIOS recovery procedure and the NUC still not booting. I recommend contacting Intel support for warranty options at:

               

              Online warranty:New Service Request

               

              Chat support:  Contact Support

               

              Allan.