3 Replies Latest reply on Sep 18, 2014 11:03 AM by joe_intel

    DN2820FYKH won´t detect SSD nor HDD: sata port 0 [not installed]

    ProC15

      I´ve just bought this unit. Installed a Kingston SSDNow 300 and 4Gb of Crucial DDR3L, and started by simply trying to install Windows 7 from external DVD. As installation didn´t detect any disk, I started troubleshooting and discovered, that I´m not the first having trouble installing Windows 7 on this unit...

       

      ...so I went on with updating BIOS to 039, made the required settings in BIOS, changed from SSD to HDD, tested both disks in another computer, wiped the disks. I even made a bootable USB and tried to install from that instead of the DVD. Nothing worked!

       

      I might have found an explanation:

      I can see, that under legacy mode, the BIOS states that SATA port 0 is [not installed].

       

      When I connect a disk (HDD or SSD) via external SATA to USB case, the disk is recognised correctly - but connected internally, the disk is absent. I´ve already tried to disconnect and reconnect both cables to the disk frame. Only thing i havent tried, is to connect disk to the Black SATA port with another cable and external power (as I haven´t got a desktop PC at this location).

       

      Do I really have a hardware failure on this brand new unit - or is there something I´ve missed?

        • 1. Re: DN2820FYKH won´t detect SSD nor HDD: sata port 0 [not installed]
          joe_intel

          Did you check if the Chipset SATA is enabled and set to AHCI under Advanced, Devices, SATA?

          • 2. Re: DN2820FYKH won´t detect SSD nor HDD: sata port 0 [not installed]
            ProC15

            Yes I did.

            In fact, I´ve tried almost every possible combination of settings in BIOS 039, but nothing Works. There are simply no visible disks. Period!

             

            So today I got stubborn, and connected my Kingston SSD via a seperate SATA-cable and an external PSU. And voila! The SSD is recognised, and I am now done installing Windows 7. Everything Works fine - just not the internal disk enclosure in the NUC.

             

            So I guess I Will have to start the process of RMA at the dealer. Unfortunately the dealer informs me, that Intel does not accept DOA on these NUC´s, but has the policy of ALWAYS repairing and returning units, whitch Means that I cannot just buy a new one and get the RMA unit refunded after it is confirmed defective.

             

            That would be sort of OK, as I can live with having an extra unit in stock. But what if the new unit has the same defect? Then I still have the original problem (no driver for an info-display) - and two NUC´s i end up having no use for...!

             

            Normally, buying two defective units would be quite unlikely. But as I can read, a lot of people have recieved several defective NUC´s - and I´m not sure I´m willing to take the risk of buying another.

             

            So I guess that I have to find another solution (Netbook, SSF or the like as I´m used to) to get my info-display up and running Again. Too bad, as the NUC would have been perfect for the job - if it had been better produced and better supported.

             

            As it is, it seems that a great idea and good design is killed by poor quality and lousy support...

            • 3. Re: DN2820FYKH won´t detect SSD nor HDD: sata port 0 [not installed]
              joe_intel

              I seriously doubt you will encounter the same issue if the unit is replaced. Furthermore, I would assume the seller can replace it if you just bought it.

              Still, I suggest contacting your nearest Intel support center, so a representative can explain you the warranty replacement options available for you.