3 Replies Latest reply on Sep 9, 2014 1:02 AM by curiousdrive

    Intel HD 4400 Bugs by older Games

    curiousdrive

      Hey,

      Yesterday i was tierd of playing League of Legends and came to the idea to install Sacred Underworld. I installed it, patched it and then... after starting the game i got following graphic bug:

      https://www.youtube.com/watch?v=ko5o4oVAcsU

       

      This was for other games as well:

      Dungeon Siege:

      http://i.imgur.com/JPXsYzt.gif

       

      Empire Earth:

      https://www.youtube.com/watch?v=V4HGWhG-a5s

       

      I run an Intel HD Graphics 4400, which is obviously the reason for these problems. Have any of you guys experience with this Intel HD Chipset, running older games? And is there a fix for that? I tried out many driver actulaisation, options in the HD panel and compatibility settings. Google found just other guys with the same errors but no solutiuon of it. I hope you could help me.

       

       

      I've seen already a thread in this board: 8.1 dont like old games graphic issues with many people ? including the same problems, but there was also no solution.

      There are still many players who want to play these older but briliant games.