1 2 Previous Next 17 Replies Latest reply on Oct 15, 2016 4:33 PM by Abdalrahman_makahleh

    Galileo Gen 2 not detected in device manager

    Drekle

      I have viewed several posts about this,  a lot of which people are having issues far past mine.  I have a Galileo Gen 2 and am having issues with windows realizing anything was plugged in.

       

      Below I have included a Screen Print of my Device Manager.  This is after I plugged the power adapter in, waited for the two lights (USB and ON) to go solid, and then plugged in the micro usb.

       

      DeviceManager.jpg

       

      Windows 7 Professional 64

      Service Pack 1

       

      At this point I am fresh out of ideas.  Any tips would be greatly appreciated.

        • 1. Re: Galileo Gen 2 not detected in device manager
          AlexanderMerz

          First of all: What do you want to achieve?

          The Galileo isn't an USB device like a printer or a keyboard. It's a computer and the USB connection is used to communicate between the Galileo and your big computer. So it is normal, that the Galileo will not be shown in the device manager. The USB connection itself should present as a serial connection in the device manager. See the Galileo Getting Started - Windows documentation, especially Step 2, for further steps.

          • 2. Re: Galileo Gen 2 not detected in device manager
            Drekle

            I would like to be able to transfer sketches from the Adruino IDE.  I have made it through step 2 of this guide.  Since my device manager is not recognizing that I have plugged in a device, I cannot install the drivers for it (Step 3).

            • 3. Re: Galileo Gen 2 not detected in device manager
              TimoK1

              Hello Drenkle and all,

              The problem is a real. I too have a new Galileo GEN2 board and there is no way of getting it running.

              The Intel instructions tell to plug the USB, detect the device in Control Panel / Device Manager, update the driver... But the Device Manager in a Windows 64bit computer running Windows 8.1 is not detecting the Galileo GEN2 usb port! Or has anyone got this working?

               

              Microsoft is working with Galileo boards within their Windows developer program for IoT. They have a Windows image on microSD for Galileo. The Galileo would be connected in ethernet to the pc and recognized there. But the windows image is for Galileo version 1 only.

               

              Anyone with any fresh ideas on how to get the first connection done?

              • 4. Re: Galileo Gen 2 not detected in device manager
                AlexanderMerz

                You could try to install the drivers manually:

                Use the Windows Explorer to navigate to the Arduino-1.5.3\hardware\arduino\x86\tools folder. Select the linux-cdc-acm.inf file and choose "Install" from the context menu.

                 

                Also: Do you use a "blank" Galileo without an inserted SD card or is there already one?

                • 5. Re: Galileo Gen 2 not detected in device manager
                  TimoK1

                  Thanks for the reply.

                  Yes, I can install the USB device drivers manually, no problem. But this does not help. The windows on the PC computer does not recognize any new device when the Galilieo USB client connector is connected to PC USB host connector. I tried this in two different computers.

                  I am booting the Galileo from internal flash. When connecting the 12 V DC the LEDs next to USB host connector on Galileo do as follows. Led "L" lights up immediately and stays on for about one second. Led "ON" lights up immediately and stays on as long as power is connected. The LEDs between USB client and host connectors "OC" and "USB" remain off even when I connect the USB client to USB host port on the PC computer.

                  The Galileo GEN2 board I received from Mouser last week.

                  I will continue on Friday and test with booting from microSD card.

                  Just to make sure I will get a working Galileo board I as well ordered one older Galileo, the version one. Can I suppose that the same SD-Card linux image will work correctly both on the Galileo version one and Galileo GEN2?

                  • 6. Re: Galileo Gen 2 not detected in device manager
                    Drekle

                    Funny my USB light comes on without connecting anything to the device ever...

                    • 7. Re: Galileo Gen 2 not detected in device manager
                      Drekle

                      arduinoInstall.jpg

                       

                      I had hope with that solution....

                       

                      As a note I have an SD card with the Linux image in my Galileo currently.  I have tried just about everything I have seen in terms of support on these forums.  I think my device might be bricked.

                      • 8. Re: Galileo Gen 2 not detected in device manager
                        PengWan

                        Folks,

                         

                        I've USB problem too with Galileo Gen 2. When I boot it without SD-Card, I can only detect it on my PC (Win 7 64-bits) for the first time. If I unplug the USB or reboot the board, the connection will be forever gone (can no longer recognize the board on the same USB port) until I reboot my PC.

                         

                        One consistent work-around that works well for me so far is to boot from SD-Card.

                        1. Download the image - LINUX_IMAGE_FOR_SD_Intel_Galileo_v1.0.2.zip.

                        2. Unzip the file into a micro-SD (it takes about ~300MB).

                        3. Plug it into your SD-slot on Galileo Gen 2

                        4. Reboot (it takes about 1 minute for this process)

                         

                        With this, my USB connection seems very robust to date. Connect/disconnect the board and rebooting the board doesn't give me any problem anymore.

                        Hope this works for you as well.

                        • 9. Re: Galileo Gen 2 not detected in device manager
                          nornagon

                          I'm running OSX 10.9.4 and my Galileo board doesn't show up in the Arduino software, nor the System Information app.

                           

                          I've:

                          - removed the SD card

                          - plugged in the power, then

                          - plugged in the USB

                           

                          ls /dev/cu.* does not contain the `usbmodem` entry, there's nothing in the Serial Ports menu, and there's no Galileo anywhere in the USB section of System Information.

                           

                          Did I get a dead board?

                           

                          [EDIT]

                           

                          Resolved, I tried a 3rd different USB cable and the device showed up. Guess I just got unlucky.

                          • 10. Re: Galileo Gen 2 not detected in device manager
                            TimoK1

                            Hello Everyone

                            Just to make sure I am not doing something wrong in Basic configuration I ordered a Galileo version one board, too.

                            Taking it out of the box, connecting the power, connecting the USB gave the expected result. The PC running Windows 8.1 was detecting the board immediately. That is because I installed the USB driver linux-cdc-acm.inf manually already earlier.

                            I opened the Galileo Arduino IDE. The Arduino sketches can be transferred to the Galileo. But those did not run. There was no activity on outputs or anything.

                            To solve this problem I made a booting microSD. The is a trig in this process. In the SD card you need to browse to the folder boot\grub. There is the configuration file grub.conf . In that file it is necessary to remove the lines

                            "

                            title Clanton SVP kernel-SPI initrd-SPI IMR-On IO-APIC/HPET NoEMU

                              kernel --spi root=/dev/ram0 console=ttyS1,115200n8 earlycon=uart8250,mmio32,$EARLY_CON_ADDR_REPLACE,115200n8 reboot=efi,warm apic=debug rw

                              initrd --spi

                            "

                            Only after that the Galileo version one was booting from the microSD.

                            I updated the Galileo version one firmware in Galileo Arduino IDE. Disconnected power. Inserted the microSD. Connected Power. Now it seemed to boot from the SD. The SD light on Galileo was blinking several times over a period of few seconds.

                            Now everything seems to work correctly on my Galileo version one. It runs the Arduino sketches, etc..

                             

                            But the Galileo GEN2 with serial number FZGL42602D9R which I ordered two weeks ago from Mouser doesn't work any better with the same microSD card. When I connect the power: The LED ON turns on immediately and stays on. The LED L turns on immediately and stays on for one second. The LEDs SD, OC, USB remain off.

                             

                            Does anyone know what would be the right procedure to go ahead with my Galileo GEN2 ?

                            • 11. Re: Galileo Gen 2 not detected in device manager
                              Mole_Catcher

                              I admit I win the Darwin award for this. After trying two cables and three different USB ports on two PCs I realized that the two lit LEDs on my board were getting power from the USB cable. I had the AC adapter plugged into a wall socket activated by a light switch, which was off. The board had no power despite two LEDs being alight. Collecting the AC adapter to a live outlet fixed the issue.

                              • 12. Re: Galileo Gen 2 not detected in device manager
                                TimoK1

                                Hello everyone, who have problems on starting the Galileo GEN2

                                 

                                There seems to be problems with individual boards. Now I have an other Galileo GEN2 ordered from Mouser. This one is with serial number SN FZGL42702G2G. This one works completely al right just taken directly from the box. It has even got the latest firmware version already installed.

                                 

                                Next thing is probably to rewrite the firmware to my first Galileo GEN2 board. There were somewhere instructions on doing that.

                                 

                                Thank you everyone who sent helpful comments!

                                • 13. Re: Galileo Gen 2 not detected in device manager
                                  Cryptoman

                                  This manual installation method worked for me on Windows 8.0

                                  • 14. Re: Galileo Gen 2 not detected in device manager
                                    riskico21

                                    hello guys, i would like to install LINUX_IMAGE_FOR_SD_Intel_Galileo_v1.0.2.zip into an SD Card in my intel galileo

                                    But i dont know why mp PC won't detect the SD Card from the galileo

                                    i already updated my galileo to the newest firmware

                                     

                                    Thank you for your help

                                    1 2 Previous Next