7 Replies Latest reply on Sep 12, 2014 7:54 AM by Psykoquack

    DN2820FYKH does nothing

    MioMio

      Hey,

      some days ago I finally got my Intel NUC DN2820FYKH. I put a Kingston KVR16LS11S6/2 in it which should be compatible according to this document: CMTL > Search > Tested Motherboard

      But my NUC does exactly nothing. I only got a black screen, my keyboard didn't work (it was also not possible to turn num lock on) and the power led is just on. To look if my NUC is broken I removed the Kingston memory. Then I got a blink code that there is a problem with the memory. So my NUC must be working basically?

      Anyways, I put the memory back in. Because I have no HDD in I should get a prompt that there is nothing to boot from. But I only get a black screen. I tried different TV's and screens, also different HDMI cables but I only get a black screen, no prompt or anything.

      This problem should be solved with a BIOS update to the latest version. I read a lot about that and downloaded the latest .BIO file, put it on an empty USB flash drive, removed the BIOS jumper from the mainboard and hoped that the BIOS update will work. But again, nothing happened. No blinking power led and so no BIOS update. I even tried four different USB sticks and also formatted in FAT, FAT32 or NTFS but nothing worked.

      Now, after 4 days of trying and searching I still haven't found any way to get my NUC working. And I also have no second memory or any possibility to test my memory if it is working. But my NUC doesn't blink when turning on so my memory must work?

      It also seems to be a bit odd that a USB LED keyboard does nothing when turning the NUC on. When I put it on my normal computer, it lights up. But not on my NUC...

      So is there any way I haven't found already? No BIOS update is working with my USB flash drives, no keyboard is working and I only get a black screen, no matter which HDMI cable or screen I use. It's just on and does nothing. Sometimes, when I have a keyboard or USB flash drive on my NUC and turn it on it just turns off again after some seconds. Then, after some more seconds it turns on again...

      I hope you can help me with that!

        • 1. Re: DN2820FYKH does nothing
          replab_robin

          I have exactly the same issue, but my memory is not on the list so I have ordered a Crucial 4Gb which appears to be on it. Just hope this is not actually a manufacturing issue. A lot of others appear to have 'issues' with these NUCs. Surprising that INTEL is unable to produce something a bit more reliable and robust against minor changes in memory etc etc.

          • 2. Re: DN2820FYKH does nothing
            Psykoquack

            Exactly the same thing here. My RAM is not on the list (Corsair cmso4gx3m1a1333c9), I started up the NUC with no memory, hoping to see the power LED blink three times to indicate a memory issue. But nothing ... power LED does not blink.

            It's going back to the reseller this evening and the next one will be tested for the power LED blinking in the shop.

            • 3. Re: DN2820FYKH does nothing
              MioMio

              So it seems that your NUC isn't working right? At least my power LED blinks how it's supposed to be. I just can't check my RAM on another computer or so...

              • 4. Re: DN2820FYKH does nothing
                replab_robin

                Psykoquack, in answer to your email. I have tried a recommended memory module Crucial CT51264BF160BJ. It improves things in the sense that I can see a keyboard being powered and my flash drive seems powered now. However, I still cannot get to see any activity on my monitor and I also am unable to get a bios update to work ie jumper out, but power button doesn't flash to indicate any update taking place.

                • 5. Re: DN2820FYKH does nothing
                  Psykoquack

                  I'm getting my replacement NUC after work, together with a RAM module that is reported as being compatible somewhere else on this forum. I'll keep you posted on this.

                  What monitor are you using? I think it must be capable of 1024x768 resolution to see the BIOS output.

                  • 6. Re: DN2820FYKH does nothing
                    replab_robin

                    After messing around trying different USB sticks I suddenly had some success. It seems the recovery boot process needs some kind of event to start it off. Started the NUC with the jumper removed and a fat32 usb stick containing FY0038.bio inserted. The power light did not flash. When I removed the stick I noticed that the power light started to flash. I inserted the stick again and the flashing continued for a couple of minutes then went steady. I powered off the NUC and connected a keyboard and my monitor using my KVM. Then inserted a stick with sysrescue on it. Powered on and found that the monitor displayed a menu. Suddenly it's all working and I have the visual bios. The 'Next' in NUC is back.

                    • 7. Re: DN2820FYKH does nothing
                      Psykoquack

                      Mine is working too ... got the new NUC in the store and tested it over there with no memory installed, but still no three LED flashes. It seemed strange to me that I would have received two defective NUCs in a row, so I took it home anyway. Installed the new memory (Kingston 4GB DDR3L 1600 MHz) and it booted properly, with immediate access to the BIOS. It seems strange that the manual mentions the three LED flashes when it obviously doesn't behave like this. Probably it was a RAM issue after all and my first NUC was also OK.

                      Got OpenELEC running on it in no time, everything works fine. Good to know the "insert stick after power-on" trick for if I ever get in trouble with the BIOS.