13 Replies Latest reply on Mar 17, 2015 4:53 PM by JanStafa

    Not able to make use of serial ports on DE3815TYBE

    Ferite

      Hi:

       

      I need to make use of the serial ports onboard of my NUC DE3815TYBE board, running Linux. I have not been able to do that. In the "Technical Product Specification" is stated that the board have a serial port header, with 2 ports in it (page 43, table 14). However I have tested the board with various Linux distros, and most of them shown only one port (tty0.):

       

       

      $ dmesg | grep tty

       

      console [tty0] enabled

      serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A

       

       

      Linux Lite Nuc however shows 3 (tty0. tty4, tty5):

       

       

      $ dmesg | grep tty

       

      [    0.000000] console [tty0] enabled

      [    1.263408] serial8250: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A

      [   56.517355] 80860F0A:00: ttyS4 at MMIO 0xd0757000 (irq = 39, base_baud = 2764800) is a 16550A

      [   56.576911] 80860F0A:01: ttyS5 at MMIO 0xd075d000 (irq = 40, base_baud = 2764800) is a 16550A

       

       

      Despite that, when I tested the ports, with a simple TX/RX terminal program, the ports are not able to send or receive.

       

      My question is, how should be recognized the ports by Linux, and how should I enable them?

       

      For the record, some days ago I did the same question to a Intel support person via chat, who told me I should boot using "Legacy" mode. Despite that, the ports still without working for me.

       

      Thanks.