8 Replies Latest reply on Aug 8, 2015 1:27 AM by Davcav

    Raid controller rs3wc080 won't start


      I Purchased a rs3wc080 to be able to ad a lot of sas disks to my pc. It is a regular machine with Asus P9x79 mobo and i7 cpu running win7 pro x64.

      The card worked out of the box, but during copy jobs of some size (30+ minutes) it would cause BSOD. After a while it would also occationally fail to start with windows, with error code 10 "this device cannot start".


      I have flashed the card and the mobo with the latest firmware and updated win drivers but the problem was just getting worse. I've also removed the card, tried it with no disks attached, down stepped the pcie slot to gen 1 and 2. Downgraded firmware. Upgraded again. Using both console and efi. All with success, but without solving the problem. Currently the virtual disks are presented to the mobo bios, and all is fine in the raid controller bios. But in windows the disks don't show, and in device manager the card shows up with error 10 cannot start.

      I even tested the card in my old pc, which has the older x48 chipset, and all worked fine even under hard load with robocopy. Since it worked in my old machine, which is running win7, I figured maybe my os installation was to blame. So I reinstalled windows, downloaded the latest driver for the card from Intel, and... Error 10...!!!!


      Any suggestions? I was thinkng of returning the card as faulty, but since it works fine in my other pcs (I've tried three now with success) I guess it actually works. Just not in the machine I need to use...

        • 1. Re: Raid controller rs3wc080 won't start

          Hello Terrak,


          Let me provide some assistance for this issue.


          Have you tried to disable some of the onboard options for your system? This would help us rule out any possible conflict or resource limitation of the board.


          I would usually disable unused onboard Option ROM such as onboard RAID, onboard NIC, Serial ports, onboard video (if using a discrete card), etc.


          Would it be possible to move the card to a different slot to compare results? I would also considering testing other cards on the same system to see if the issue follows the PCI Express* slots of the board. 

          • 2. Re: Raid controller rs3wc080 won't start

            I've disabled all on board devices, even those I normally use, that the BIOS will allow. Except the SATA controller from which my OS runs (it's not in RAID mode), and the PCIe slot where my graphics card resides. But with no success. The rs3wc080 is always ok both in the mobo BIOS and it's own BIOS. Noe errors or conflicts ever reported. But once I get in to Windows the card won't start. As I mentioned before it used to start, but was unstable. For the last 100 reboots it consistently will not start. Ever.


            I have tested the same card in three different computers. A Z820 work station, a PC with Asus Rampage mobo, and in my old PC running some older x48 chipset mobo. It works just fine in all of these, leaving me to think that the P9x79 mobo of my original machine is to blame. But I've also tested several other PCIe cards on this mobo with no error. This includes two different HP controller cards. Never any issues. So they both work fine, except when they are together. Bad marriage...


            Could there be some kind of special setting that this particular card needs? Or is there a general compatibility issue between this model of cards with this model of mobos (or chipset)?

            Both have the latest firmware. I've thought about downgrading one or both to even older firmware, but I can't really see much hope in that.

            • 3. Re: Raid controller rs3wc080 won't start

              I am still investigating further to see if there is anything else we could try to make it work. I will post an update as soon as I have more information available.

              • 4. Re: Raid controller rs3wc080 won't start

                I was wondering if you have tried to reverse the installation of the cards. In other words, to install the RAID controller to the top slot (closest to the processor) and then install your video card to the second x16 slot. I am trying to see if this would make any difference on how the board would allocate resources.

                • 5. Re: Raid controller rs3wc080 won't start

                  That's probably the only slot I didn't test earlier, but after your post I did. Works fine in bios, but in Windows it's still giving error 10. Not matter which slot, which PCIe generation I set it to, and no matter what I disable of onboard devices. Currently only SATA and two PCIe slots are active in the mobo bios. One for graphics and one for the raid controller. I even tried different graphic cards and hard drives to rule out some freakish compatibility issue. No luck.


                  Everything else I throw at it, like other raid controllers, more graphic cards, FireWire cards etc, works fine in any port under any load. And the raid controller works fine in any other computer I've tried  except the one I need to use. So I guess it comes down to this; the P9X79 mobo is incompatible with RS3WC080. At least that seems to be the case with my specific samples of the two.

                  • 6. Re: Raid controller rs3wc080 won't start

                    I am trying to see if I can find feedback from other customers that might have used the same configuration in the past and see if it worked for them or not.

                    • 7. Re: Raid controller rs3wc080 won't start

                      It appears that this would be a compatibility conflict between the board, and the RAID controller card. I have not yet been able to find enough feedback from others that would make us think otherwise.

                      • 8. Re: Raid controller rs3wc080 won't start

                        I have exactly the same problem.


                        Brand new Gigabyte GA-H97-HD3 motherboard, I7, 16 GB ram and latest version of Win 7.


                        Raid card loads and can configure disks.

                        Raid is seen in Bios.

                        Boot up Win 7 and I can see the Raid card, I can install the driver but get error 10, cannot start hardware error.


                        All peripherals that I can have been turned off, raid swapped between the two PCI-E slots, everything upgraded that I can (RAID card bios upgrade is still being worked on) but nothing seems to be working in getting this card operational.