4 Replies Latest reply on Sep 1, 2014 8:37 AM by Johnson23

    Nuc 34010WYK and Win 7 - CIR not working

    Johnson23

      Hi!

       

      First off, the intel NUC is a wonderful little machine, and I enjoy it a lot!

       

      However, I am currently struggling to get the built-in Nuvoton CIR to work running Windows 7 Professional 64-bit. I have the latest drivers, and it shows as both Nuvoton and eHome devices in device management. I am using an Xbox 360 media remote, and it should work with the eHome driver as well (accordinmg  to several sources). I've seen a registry hack where Windows should listen to all IR channels, and have performed that one. But nothing works.

       

      I have both the eHome and Nuvoton devices listed in device management, should both be there, or should only the eHome device be?

      I am using eventghost to try and register any inputs, but nothing is registered.

       

      Do you guys have any suggestions to any software that can be used to check if any signals are being registered with the CIR on win 7? I know it isn't hardware related, as I got the the built-in receiver to work with an apple remote on linux.

       

      How do I get the built-in CIR to work with any remote on Windows 7? If you can specifically help with the xbox 360 media remote, that would also be awesome

        • 1. Re: Nuc 34010WYK and Win 7 - CIR not working
          dougho

          What is it that you are trying to do with the remote in Windows 7?  Are you in the "Media Center" program of Windows 7 and trying to use things like arrows and fast forward and pause and so forth?  If so, I think that is what the registry change you mention is for.  I think your Xbox media remote sends out code 8 while a normal Media Center remote sends out code 1 (although remote can be changed by a button press procedure).  So you change that registry entry from a 1 to an 8, then save and reboot.  There are also other ways you could change the registry, I think that 0 means accept any code, or you could change the 2 3 or 4 to the 8.   I could be mistaken but I think the Nuvoton CIR part is the lower level hardware driver and the eHome part is a higher level portion (intended for Media Center).

          Having said that, the NUC seems to also have some special case for powering on from the remote - and the most recent BIOS version was needed for that power on function in the case of the Xbox remote (code 8).  I have been unable to find out how to control that power on feature.  Power on seems to react to all codes (1-8) rather than being able to selectively program the codes like you can in Windows.  It is also powering on when the Pause button is pressed - that seems strange to me.  I am probably one of the few people who have multiple NUCs in one room, and that doesn't work well like I use to be able to do with multiple Intel non-NUC PCs in a room.  The IR has worked fine for a decade like that, powering up only from standby/suspend (and never when the pause button is pressed).  But the NUC changed that, they are also powering up from "off" and are listening for multiple codes rather than being selective (and the pause button, which sure seems like a bug).

          • 2. Re: Nuc 34010WYK and Win 7 - CIR not working
            Johnson23

            I have both tried the official Windows media center, nothing happens. Have also tried in Xbmc with an MCE addon. Nothing happens. And yes preferably as many buttons as possible should work. Only buttons I seem to get to work are the ones associated with the TV, as the Xbox 360 media remote has the ability to turn on/off TV as well. If I uninstall the eHome driver and keep the Nuvoton, I am not able to see the device in e.g. evenghost either, so definitely need both devices/drivers in device management.

             

            So far this is what I have tried:

            - Changing only CodeNumSet0 - to both value 8 and 0. With restarts in between. And also having uninstalled the Nuvoton and eHome drivers.

            - Changing both CodeNumSet0-3 - to both value 8 and 0, also with restarts in between and a couple of uninstallations of Nuvonton device.

            However, I have only changed those registryhacks in the remote "745a17a0-74d3-11d0-b6fe-00a0c90f57da", and not the other ones (see pictures)Documentation1.PNG).

            Documentation2.PNG

             

            Still no reactions in either Windows media center or Xbmc. Can it be due to running Windows 7 Pro 64-bit?

            Should there be performed other registry hacks when running Win 7 Pro?

             

            Sounds annoying with bootup on several codes 1-8. Personally I could manage to not being able to turn on the NUC from S4/S5 state, although it would be nice!

            Currently I just want the remote to work with the built-in reciever. Not sure if you're familiar with Evenghost, but since the Nuvonton is filed under HID devices, i figured the signals would pop-up using an "Generic HID" evenghost plugin, where i pick the nuvoton HID device, but no.

             

            Thanks for the Help @dougho!

            • 3. Re: Nuc 34010WYK and Win 7 - CIR not working
              dougho

              Seems like you are doing what I would expect to work (although I do not have an Xbox remote).  The most obvious thing would be to question whether the remote itself is working - batteries or whatever (I think that you said the NUC receiver part is working).

              • 4. Re: Nuc 34010WYK and Win 7 - CIR not working
                Johnson23

                I have also thought about that, but it works with my xbox 360, which is right next to my NUC. And it also works with the TV, to control the volume and input. I am considering deleting Win 7 pro and installing win 7 premium. Maybe the drivers work better with that OS? Or maybe a fresh install with new OS is what the NUC needs.

                 

                But thanks anyway! Any advice is much appreciated. So if anything comes to mind, you are more than welcome to write again