3 Replies Latest reply on Aug 30, 2014 4:45 PM by Piol

    Node and rdate -s nist-time-server.eoni.com


      Every time I reboot my device, I have to enter this to npm install anything or I get the error CERT_NOT_YET_VALID:

      rdate -s nist-time-server.eoni.com


      Is there a more efficient solution? Would adding a clock to my board help?


      Thank you!

        • 1. Re: Node and rdate -s nist-time-server.eoni.com

          Hi jd1000


          I think I’m not understanding your question. If you are having problems when installing programs in your board due to the date of the Yocto, maybe you can try with the following command:

          date 082616472014.05

          To explain the format of this command the first two digits correspond to the month,  another two for the date, two for the hour, two for the minutes, four for the year then a dot and two more for the seconds. Also you can try by using a cell coin to enable RTC. If this is not what you are asking, please let us know so we can help you.



          • 2. Re: Node and rdate -s nist-time-server.eoni.com

            That may be the solution -- I'm looking for something that won't reset when I shut down the board. I'll try it and let you know. Thank you!

            • 3. Re: Node and rdate -s nist-time-server.eoni.com

              I managed this issue with this:

              Edit this file (/etc/init.d/galileod.sh) with WinSCP or trough vi command.

              After this line (line 32),

              start-stop-daemon -q -S -m -p $pidsreset -b -x $sreset -- -i $input_reset_gpio -o $output_reset_gpio

              Create new line, and add your command:

              rdate -s nist-time-server.eoni.com

              Save, then reboot.


              Why I edited this file (/etc/init.d/galileod.sh) ?

              - I have checked dmesg, and this is the last message after all kernel boot. So, at this time, board already gets his IP from router and will be able to update the date.



              R. Piol