2 Replies Latest reply on Aug 27, 2014 9:03 AM by kevin_intel

    DN2820FYKH SATA drive not recognized

    hog23241

      Hi all,

      I own a DN2820FYK since roughly 3 months, and so far I am pretty impressed by the little box. Right now I am facing some issues that I hope you can help me resolve, as I have had no luck so far.
      Here goes:

       

      After unboxing 3 months ago, I updated the BIOS,  attached a USB3.0 External HDD to the NUC, booted from a Live usb stick and installed XBMCBuntu on the external disk. Flawless, no issues whatsoever.

      I have been using this setup for a while and would now really like to switch to regular (desktop) Ubuntu for various reasons. As I could also really use the extra USB port and don't want the hassle of USB-hubs, I thought it would be a good time to change to using the internal SATA port of the NUC.
      After backing up the data, I formatted the USB3 drive,  disconnected the USB3.0 drive, opened it up and indeed found a 2.5" Sata Toshiba 1TB notebook drive (MQ01ABD100) connected to a SATA to USB3.0 controller. In took the disk out and installed it in the NUC.

      I created a Ubuntu live USB stick, booted into the Ubuntu installer only to find the disk not recognized. No disk hardware is found at all.

       

      I connected the Toshiba internal drive (using SATA) to my windows machine to find it was working perfectly. I formatted the drive (again) and deleted all volumes/partitions, so it now shows as 1 TB of continuous un-allocated space. Reinstalled the drive into the NUC, updated the NUC BIOS (0038 rev.1455). The BIOS does not detect the disk at all, it is not selectable in the boot selection menu, and the drive does not spin up. At first I thought about a bad SATA controller or connection, but Live Ubuntu's lspci command neatly shows the SATA controller being present.
      After this I did a BIOS reset (using the yellow jumper) and tried the whole procedure again, to no avail.
      BIOS SATA settings are left at default (although I tried all options) as this is supposed to be correct for using SATA drives.

      I would really hate having to go back to using the External HDD as the primary drive for the NUC.
      Any help or suggestions would be greatly appreciated!

        • 1. Re: DN2820FYKH SATA drive not recognized
          hog23241

          An update to this issue. Hopefully useful for someone in the future who encounters this.

           

          As the symptoms in the first post include the drive not spinning up at all, I suspected an issue with the power to the disk.
          Disconnected the disk, removed the SATA and SATA power cables from the NUC. Then I connected a regular desktop SATA cable from the NUC motherboard to the Toshiba disk, and setup a separate ATX power supply next to the NUC. I used the ATX to power the disk drive using a SATA power connector. Fired up the NUC, and sure enough the disk is recognized in the BIOS and fully functional.

           

          Next step was to reinstall everything in the NUC (so the factory SATA and SATA power cables) and turn the NUC on, to measure the voltages on the SATA power connector to rule out a faulty cable. I measured the small PCB that connects to the disk at the power connector and the PCB does receive the proper +5V and +3.3V (red and orange wires).
          At this point I could have probed further to see where the problem lies, because some connections on the small PCB look suspicious to say the least. However this has already cost me 2 evenings and by now I am certain it is a HW defect that was already present when I purchased the unit, it just has gone unnoticed so far. I will be sending the NUC back for warranty, but I would not be surprised to see more NUC's with similar defects.

          • 2. Re: DN2820FYKH SATA drive not recognized
            kevin_intel

            We are really sorry for this inconvenience. Here you have our contact support information:

            http://www.intel.com/p/en_US/support/contactsupport

             

            Kevin M