2 Replies Latest reply on Aug 26, 2014 7:24 AM by geoslake

    Nuc Hd5000 losing vsync

    geoslake

      Hi

       

      Im running windows 8.1 64 on an intel nuc i5 haswell, using latest drivers (10.18.10.3910)(but had the same problem with previous version).

       

      The only game I need to run is Nascar 2003.

       

      I need vsync enabled to get smooth 3d, problem is, the hd5000 is sometimes "losing" vsync, especially in turns (so, when the scenery is changing a lot, i guess).

      There is an FPS counter in the game, and what happens is that the fps goes above 60fps for a fraction of time (say, 1/10s, very short period), can be 65fps, or 100fps etc.

      It is not the gpu or cpu beeing overloaded, if I disable vsync, fps is above 140fps for the whole track/race.

      I also tried with a fixed cpu speed (forcing maximum performance) with no change.

       

      If I run the same game with the exact same os and settings, except on an nvidia card, ive got no problem at all.

       

      I know it's an old, unsupported game, but its the only one i'm interested in (beside emulators).

       

      Could it be the GPU throttling, and causes those vsync loses at the moment it changes speed ?

       

      Thanks for the help

        • 1. Re: Nuc Hd5000 losing vsync
          sylvia_intel

          Hello Geoslake, I am sorry to hear that you are having this kind of problems on your system, but it looks like this behavior is caused by compatibility between the graphics and the game.


          These games you are playing are older than your HD graphics; so this is an expected behavior. I recommend you contacting the game developer in order to find out if this is a compatibility problem or something else.

           

           

          Something important that I would like to share with you is that in order to have Vsync always enable, it will be necessary to select "driver settings" in the Intel HD graphics control Panel.


          vsync.JPG

           

          Regards,

          • 2. Re: Nuc Hd5000 losing vsync
            geoslake

            Thanks Sylvia, of course the developers (sierra) don't support this game anymore

            Although the fact that there's no problem on nvidia (and ati btw) leads me to think that Intel drivers are culprit here, not a game which has been working flawlessly for more than 10 years...

             

            I'll at least try to find a driver archive, maybe an older version will do.

             

            Thanks