10 Replies Latest reply on Oct 28, 2014 9:03 AM by sylvia_intel

    DN2820FYKH and USB/UEFI boot

    Will3r

      (this is a concatenation of my findings in someone else topic, which seems dead)

       

      I Ran into some annoying boot-issues using USB sticks in the later bios releases for the Celeron NUC.

       

      Last week I purchased the NUC for dedicated OpenElec use.

      - DN2820FYKH

      - Sandisk Extreme 16GB USB 3.0

      - 4GB DDR.

      - Tried both OpenElec 4.0.7 (stable) and 4.1.4 (beta) x86_64 [diskimage] using Rufus.


      With the shipped BIOS, it booted to the USB stick, but the BIOS seemed a bit buggy.

      Decided to upgrade to the latest Bios FY0038; the system boot anymore, none of the options made it read the stick's contents.

      Tried the same stick in my laptop (Dell E6540), no problem.

      Downgraded NUC BIOS to FY0021, and exactly the same stick would boot without any issue!


      Decided to do some additional testing, fresh-start;

      - Used BIOS FY0021 (default settings), created a bootable USB2.0 stick with the openelec installer.

      - Started the system, booted the openelec installer from the USB 2.0 stick, and installed openelec to the Sandisc USB3.0 stick.

      - Restarted the system and successfully booted to the USB 3.0 stick (succes).

       

      Out of curiosity, i did the following;

      -Restarted the machine, flashed to FY0038 and rebooted again.

      -OpenElec would boot from the installed USB3.0 stick now!

       

      Put the USB2.0 stick back into the system, still containing the installer image.

      Removed the USB3.0 stick with OpenElec, and restarted the machine, No boot, weird!

       

      Comparing the differences:

      - The USB2.0 stick was UEFI boot

      - The USB3.0 stick was legacy boot

       

      Appears as if UEFI boot is not working properly on the FY0038 release..?

      Funny though, in the box I found a yellow paper stating you can install operating systems using a USB stick of USB optical drive, but it is recommended to upgrade to the latest/greatest BIOS... Seems like an impossible task :-)

       

      Spend some extra time in trying different BIOS versions.

      After flashing to almost every available BIOS, it seems the OpenElec 4.1.4 x86_64 [DiskImage] USB-stick (UEFI) boot stopped working in BIOS FY0034, so I am currently running FY0032, which appears works fine.

       

      As a last resort, I checked the available documentation :-)

      I found this on the Intel site as tested for OpenElec:

      Tested with the development build at OpenElec.

      1. Press F2 when prompted during boot to enter BIOS Setup.
      2. Press F9 to set all BIOS options to default values.
      3. Select Advanced.
        1. On the Devices and Peripherals > SATA menu,Chipset SATA Mode is set to AHCI.
        2. On the Devices and Peripherals > USB menu,USB Legacy is enabled (checked).
        3. On the Devices and Peripherals > Video menu,IGD Minimum Memory is set to 512 MB.
        4. On the Boot > Boot Priority menu:
          1. UEFI Boot is disabled (unchecked).
          2. Legacy Boot is enabled (checked).
        5. On the Boot > Boot Configuration menu, USB under Boot Devices is enabled (checked).
      4. Press F10 to save your changes and exit BIOS Setup.
      Proceed with the installation of the operating system.

      I Did exactly this, and the machine reports no bootable device using BIOS FY0038.

      Used both the 'diskimage' and the 'create_installstick' tool; no startup from USB stick.

       

      My personal conclusion would be that something changed in the devices boot-code from BIOS version FY0034 and up, which prohibits it from starting up UEFI (GPT) written USB devices.