3 Replies Latest reply on Jul 16, 2015 6:27 PM by MonaJalal

    Linux install to make node-gyp work on Galileo

    jd1000

      I've had good luck running the SD card Linux image currently available on the downloads page (Software Downloads) with the updated node install on the Galileo.

       

      But now I need some node packages that apparently need "make", which isn't available with the SD card Linux image I'm using.

       

      It sounds like there are several possible solutions, but I'd love to hear what worked for people to get things like "npm install spi" to stop choking at the node-gyp step because it can't find make.

       

      It sounds like make is included in the iotdevkit download, but the link (https://software.intel.com/en-us/iotdevkit) I've tried either never connects or redirects to the ConnectAnyThing landing page.

       

      I've found a bunch of code here, but I don't know how to make a working SD card image out of it.

      meta-intel-iot-devkit - Intel IoT Developer Kit metadata

       

      I found something promising here, but I won't know for 2 hours if it's the right thing.

      IOTDK download location

      It also looks like I might be able to opkg install make with one of those ipk files, but I don't know which one.

       

      Then there's Debian, which looks like it wants bitbaking. Can I do that from a Virtual Machine (I'm on a Mac)?

      IntelGalileo/Debian - ROS Wiki

       

      While I wait for help (thanks in advance!) and downloads, I'll probably fire up a Virtual Machine and try to "bitbake" this:

      alext-mkrs/meta-alext-galileo · GitHub

       

      Am I on the right track with any of this to get "npm install spi" working?

       

      Thanks!