1 2 Previous Next 19 Replies Latest reply on Dec 22, 2014 3:25 PM by joe_intel

    SSD Toolbox crashes after launch

    eidam655

      Since the purchase of my Intel SSD drive (Intel SSD 335) I am unable to run the SSD Toolbox software. I have tried with the then-current version (3.1.0) and three consequent versions (3.2.0, 3.2.1 and lastly 3.2.3).

       

      The issue is always the same - I install the software without problems, but after launching the application it crashes with the typical Windows' "application has stopped working" modal.

       

      I have contacted support a few times already with this issue, but it's gone nowhere; today I performed two tests with the software:

       

      I installed the SSD Toolbox on another computer, where it had no problem with running (note: there are only HDDs installed on said computer), while on my laptop (where my SSD is installed and used as the only/primary disc) the toolbox kept crashing (always referencing a faulty msvcr90.dll - multiple versions, removals, reinstalls or updates did not help at all.).

       

      So, using Microsoft's Dependency Walker I ran the software on both PCs, with 'Profiling' option on and after reviewing the logs I found one difference - some libraries aren't being run/loaded on the 'faulty' machine. The diff of both logs is available at this link - http://www.diffchecker.com/j4p4joi4 - on the left is the log of the 'running' machine, on the right the faulty one.

       

      They are pretty much the same (only the addresses change) until the line 1812, where the 'OK' machine runs a few wintrust.dll & setupapi.dll functions, while the other one doesn't at all. After few more lines, at 1850, an exception occurs on the 'faulty' one, which then propagates to the end of the log and the program termination.

       

      I'm using (on both machines) Windows 7 64-bit. I'll be happy to supply more debug data if requested.

        • 1. Re: SSD Toolbox crashes after launch
          joe_intel

          Hi eidam655, thank you for posting in Intel Support Communities.

           

          I suggest you repairing your Microsoft* .NET framework installation; this is very easy to accomplish by opening Programs and Features, highlighting this software component and clicking Uninstall/Change and then you can click Repair. I am very positive this will help because the log appears to be pointing at it.

           

          I also found after a quick online search that msvcr90.dll is related to the Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package. Uninstalling and reinstalling this package may help too.

          • 2. Re: SSD Toolbox crashes after launch
            eidam655

            hi Joe,

             

            i tried repairing the .NET 4.5.1 package installed and also tried to uninstall and reinstall all the Visual C++ 2008 redistributables, but nothing helped; the application still crashes after launch.

            • 3. Re: SSD Toolbox crashes after launch
              joe_intel

              Please share more information about your system, such as: processor, chipset, SATA controller model and SATA mode (AHCI, IDE, RAID). You may also attach the msinfo32 report with the Advanced Editor (press Windows* key + R key, type “msinfo32”, press OK and then File, Export).

              • 4. Re: SSD Toolbox crashes after launch
                eidam655

                i'm on a laptop (lenovo x200 tablet, 7449-fxg) with an intel SL9400 1.86GHz CPU, SATA is in AHCI mode, the SSD is the only drive in the system.

                 

                i'm attaching the msinfo32 report.

                • 5. Re: SSD Toolbox crashes after launch
                  jkingma

                  I had exactly the same and went back to 3.1.6. That works fine.

                  • 6. Re: SSD Toolbox crashes after launch
                    eidam655

                    as i wrote in the original post, i have tried it with 3.1.0... but could you perhaps link me to the 3.1.6? it's worth the try, if nothing else.

                    • 7. Re: SSD Toolbox crashes after launch
                      joe_intel

                      eidam655, I have sent you a PM.

                      • 8. Re: SSD Toolbox crashes after launch
                        eidam655

                        thank you joe. i tried the v3.2.1 that you sent me, but i still get the appcrash.

                        • 9. Re: SSD Toolbox crashes after launch
                          joe_intel

                          Let's try with 3.1.6, again via PM.

                          • 10. Re: SSD Toolbox crashes after launch
                            eidam655

                            thank you joe; but to no avail.

                             

                            my biggest problem is that i can'r really tell why the app keeps crashing. it's obviously some kind of a magic combination of my hardware and software packages; i just wish i knew what was happening :/

                             

                            can the toolbox be run from a command line with some sort of verbose output?

                            • 11. Re: SSD Toolbox crashes after launch
                              joe_intel

                              eidam655, I am sorry for my delayed response.

                              Please check the suggestion I posted here: https://communities.intel.com/message/249343#249343

                              Let us know if this works.

                              • 12. Re: SSD Toolbox crashes after launch
                                eidam655

                                hi joe,

                                 

                                i left a response in that thread.

                                • 13. Re: SSD Toolbox crashes after launch
                                  eidam655

                                  okay guys,

                                   

                                  SO something incredible happened

                                   

                                  I found out that the application errorcode was c00000005, which means 'access violation exception.' so after a while of googling around i found this answer directing me to try to create a dump file out of the crash. i created the mentioned registry keys, downloaded ProcDump 7.0 and tried to get the dump.

                                   

                                  after few tries with the command line i got this line working:

                                   

                                  "C:\Program Files (x86)\Intel\Intel(R) SSD Toolbox\Intel SSD Toolbox.exe" & procdump.exe -ma -e 1 "Intel SSD Toolbox.exe"

                                   

                                  ...which ran the program and immediately ran the debug process so it would catch the exception and create a dump out of it.

                                   

                                  incredibly, when i ran it the first time this way, the toolbox ran without any crashing, straight into menu, telling me it's never been run before and that there's a firmware update etc.

                                   

                                  so i closed the application, tried it again with the command line - and no crashes again.

                                   

                                  HOWEVER, since the third time's a charm, i ran the command one more time - but this time the application reverted to its 'default' behavior, ie. crashing with an access ciolation exception.

                                   

                                  good news is, i've got the dump out of it and it is available at https://dl.dropboxusercontent.com/u/50406255/Intel%20SSD%20Toolbox.exe_140905_163923.dmp (it's 150MB though; but it could be useful to someone with app's source code, i hope )

                                   

                                  EDIT: i should also add that i removed the files "Microsoft.VC90.CRT.manifest", "msvcm90.dll", "msvcp90.dll' and "msvcr90.dll" from their default location into a temporary subfolder. I ran the SSD Toolbox v3.2.3.

                                  I tried running the command combo again and the Toolbox successfully launched again. The successful runs seem to be completely random, though, so i'm still a bit scared to run the firmware upgrade.

                                   

                                  EDIT 2: you might be onto something with the TurboMemory drive thing. After the toolbox launched, there was a 1GB drive in the Other Drives category, and when i tried clicking on it, the app immediately crashed.

                                   

                                  EDIT 3: yes, this behaviour is consistent whether the TurboMemory drive is set to Offline (through Windows' Disk Management tool) or Online, whether it's controlled by TurboMemory, or the partition is deleted, reformatted (FAT32/NTFS), the SSD Toolbox always crashes immediately after I click on this partition in the Toolbox. I'm guessing the Procmon command combo somehow delays the TurboMemory drive initialization, and that's why I'm occasionaly successful in launching the application.

                                   

                                  This is progress, gentlemen!

                                  • 14. Re: SSD Toolbox crashes after launch
                                    eidam655

                                    bump?

                                     

                                    //EDIT: Okay, it seems I figured it out

                                     

                                    What I did was I opened the Intel Turbo Memory Console, unchecked both Windows ReadyBoost and Windows ReadyDrive functions (restarted the pc when prompted both times), opened Disk Management, right-clicked the IMD-0 drive and set it to offline, uninstalled the Turbo Memory driver, restarted, and voilà.

                                     

                                    Device Manager is now showing an unknown device, there is no extra drive in Disk Management, and Intel SSD Toolbox 3.2.3.400 runs perfectly fine.

                                     

                                    So I guess my year-long issue is solved

                                     

                                    (now another question arises - is there any way I could get the Turbo Memory thing working as a paging partition and still use the Toolbox? Hm hm... But let's leave that for another thread )


                                    //EDIT2: okay, so I fiddled with it some more and reinstalled the Turbo Memory driver. After the compulsory restart I opened Turbo Memory Console, disabled ReadyBoost (& rebooted), disabled ReadyDrive (& rebooted again), formatted the 1.3GB partition with NTFS and assigned a letter to it, and now I can use both disks while being able to run SSD Toolbox the new partition isn't showing up in the Toolbox, but I guess that's not a problem.

                                    1 2 Previous Next