3 Replies Latest reply on Aug 26, 2014 10:59 AM by joe_intel

    .NET 4.0 errors trying to run IPDT 2.8.0.0

    george.h


      Hi,

       

      I've got a Dell PowerEdge 800 server which keeps locking up. I've narrowed it down to either the system board or CPU. However all the diagnostics (from Dell) I've run so far have shown nothing. Nothing shows up in RAM tests (apart from it locking up DURING the RAM tests if left long enough). So I thought I'd download and install IPDT (IPDT_Installer_2.8.0.0-1_x86_2.10.0.0.MP-1_x64.exe). The systems itself is running Windows SBS 2003 SP2 with a PERC 4SC RAID controller running the HDs.

       

      Now, everything installed fine including .NET Framework Client 4.0 and the C++ Runtime 2010. However when I try and run IPDT I get the dialogue box for:

       

      "Reading system information and preparing Intel Processor Diagnostic Tool for launch. Please wait....."

       

      After a few seconds the dialogue box disappears, then nothing - no IPDT. If I look in the Application event log I always get two errors logged immediately after trying to run IPDT (see attached screen captures). The second error is shown as two images, the second after scrolling down in the event window.

       

      Anyone any ideas how to get this working?

       

      Much appreciated.

      George

        • 1. Re: .NET 4.0 errors trying to run IPDT 2.8.0.0
          joe_intel

          Hi George, perhaps it will work better after repairing the Microsoft* .NET framework installation from Programs and Features, you just need to highlight the software component and choose Uninstall/Change.

           

          I believe the results you are getting are not very conclusive but you can still try other troubleshooting steps:

          • Use a single memory stick for testing, and then swap it with a different one in order to determine if one of them is defective.
          • You may use the bootable version of the Intel® Processor Diagnostic Tool.
          • Try removing all other hardware components (add-in cards) and testing the system in minimum configuration.
          • Use a different hard drive with a freshly installed operating system just for testing; there may be bad sectors in the other hard drive(s) or the operating system may be tampered or corrupted.
          • 2. Re: .NET 4.0 errors trying to run IPDT 2.8.0.0
            george.h

            Hi Joe,

             

            Many thanks for your suggestions. I did eventually download and use the Fedora bootable ISO version, burning it to CD instead of USB as I'm not sure the PowerEdge 800 will boot from USB. Anyway that worked, if a bit confusing having to manually install IPDT from a shell window. I'm sure Intel could build a better Live Fedora ISO for the next version that doesn't need this step.

             

            The results of running the diagnostics didn't reveal anything - even running the stress tests for 3 hours. It did help eliminate the processor though. I needed to do that as when the freezing issue started the system hardware log (not the Windows server system log) was logging "CPU Sensor Processor IERR" events, which indicate the CPU was asserting IERR to flag an internal error. So my first line of attack was to give the whole machine a good clean out (the heatsink was rather clogged with dust/cat hairs/dirt etc). That didn't do anything so I swapped the CPU for another P4. Same result with no change in frequency of the lock-ups. So I then ran several memory tests using both Dell's system diagnostics from within SBS 2003, from bootable CD and also Memtest86 from bootable CD.

             

            The fact that the system even froze up during the memory tests booting from CD (no pattern as to where in the tests or after how long) and that no memory problems were logged indicated it probably wasn't the RAM. Just in case I followed your suggestion and removed one of the two 1GB DIMMS, ran it - it froze. Took that DIMM out and replaced it with the other one than ran the server - still froze. Still no RAM errors logged either by the memory test software or in the system hardware log (it has ECC RAM). This also eliminates the OS and hard drives (4 SCSI drives in RAID 5 via a PERC 4/SC RAID controller) as the problem as it wasn't using booting from or even using them and it still locked-up.

             

            As I final test I removed the CPU heatsink again as well as the two heatsinks on the mainboard chipset chips and renewed the thermal compound. That did have an effect on the lock-ups in that it can now stay up and running for anything from a coupe to 8 hours before it locks up - before they could occurr after just 30 mins. I (usually) know precisely when the lock-ups occur as I've got the baseboard management controller (BMC) set to reboot the system (using a hardware watchdog timer set to timeout after 480 seconds) when Windows Server is running if the server freezes.

             

            So I think it pretty much says the mainboard is the problem so time to find a new one (or a new server!) on eBay...

             

            George

             

            • 3. Re: .NET 4.0 errors trying to run IPDT 2.8.0.0
              joe_intel

              I am glad you were able to find the cause of the issue.