2 Replies Latest reply on Aug 15, 2014 3:41 PM by sleef

    Problem with HD 4600 displaying beyond 1024x768


      I'm having an issue with the Lenovo M93p with the i5 HD 4600 connected to a KVM switch then an HP 2211x monitor. I have 3 other units at work running at 1920x1080 on said HP 2211x monitor. All the other units are G41 express chipsets GMA 4500 and all those work fine. However, the HD 4600 refuses to display anything beyond 1024x768 even when I set a custom resolution manually. I can connect it directly to the monitor and it works fine but switches back once connected to the StarView Professional KVM switch. The video is connected via the VGA port to the KVM which works with all the other units we have so it's not a problem with the port on the switch.The adapter lists no mode beyond 1024x768 and it ignores anything I do to set it beyond that no matter what I try.

        • 1. Re: Problem with HD 4600 displaying beyond 1024x768

          Thanks for joining the Graphics community.


          I understand you are using a KVM switch that does not display proper screen resolution.

          Please bear in mind that Intel does not provide assistance for KVM issues. You need to address this matter directly to your computer manufacturer.

          The usage of KVM switches will limit screen resolutions; it might be locked at vbios.


          I have been checking this information with our engineering team and this is their response:


          "I believe that was caused by the KVM switch you have, that did not successfully feedback correct the display's EDID between connected PC and your display.

          I suggest put an EDID emulator between connected display and console video port of the KVM switch. But before you do that, you need to have the emulator "clone" the correct EDID of your display first".



          • 2. Re: Problem with HD 4600 displaying beyond 1024x768

            I was able to correct the issue by editing some registry values. I now have it displaying 1920x1080 as well as the lower resolutions. Thanks for your response.