6 Replies Latest reply on Aug 11, 2014 1:55 AM by mhahn

    WiFi not working in yocto image

    anbu369

      Hi.. I am trying to use this image http://eem.bime.ntu.edu.tw/resource/clchuang/Clanton_Full_SDK_OpenJDK6_Tomcat7.7z for my project. The image is working fine but I cannot upload any arduino sketches as the board is not detected after booting from SD card. I need to access the wifi. So I followed Intel Galileo Meets Wireless - Malinov Family Web Presence to setup mu Wi-Fi. I have the 135 chip. The firmware is installed and I gave my credentials and when I execute, /etc/initid.d/networking restart, it shows the following error

       

      Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces

      Reconfiguring network interfaces...

      ifdown: interface wlan0 not configured

      ifdown: interface eth0 not configured

      SIOCSIFFLAGS: Operation not possible due to RF-kill

      udhcpc (v1.20.2) started

      Sending discover...

      Sending discover...

      Sending discover...

      No lease, failing

      So I looked up RF-kill and found that my wifi is softblocked so I used 'rfkill unblock wifi' which gave the following error

       

      root@clanton:/etc# rfkill unblock wifi

      root@clanton:/et[  697.103912] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S

      c# [  697.129599] iwlwifi 0000:01:00.0: Radio type=0x0-0x0-0x0

      [  697.440675] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

      But when I rebooted the board, the log shows that the board is connected to mu Wi-Fi but de-authenticates itself. This is what I get while booting

      Starting Bootlog daemon: bootlogd.

      ALSA: Restoring mixer settings...

      /usr/sbin/alsactl: load_state:1696: No soundcards found...

      Configuring network interfaces... Successfully initialized wpa_supplicant

      [   25.154184] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S

      [   25.167566] iwlwifi 0000:01:00.0: Radio type=0x0-0x0-0x0

      [   25.407142] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S

      [   25.420523] iwlwifi 0000:01:00.0: Radio type=0x0-0x0-0x0

      udhcpc (v1.20.2) started

      Sending discover...

      [   26.325786] wlan0: authenticate with 7c:4c:a5:54:ac:b9

      [   26.379122] wlan0: send auth to 7c:4c:a5:54:ac:b9 (try 1/3)

      [   26.415204] wlan0: authenticated

      [   26.421173] wlan0: waiting for beacon from 7c:4c:a5:54:ac:b9

      [   26.510241] wlan0: associate with 7c:4c:a5:54:ac:b9 (try 1/3)

      [   26.521195] wlan0: RX AssocResp from 7c:4c:a5:54:ac:b9 (capab=0x411 status=0 aid=5)

      [   26.540720] wlan0: associated

      Sending discover...

      Sending select for 192.168.0.18...

      Lease of 192.168.0.18 obtained, lease time 86400

      /etc/udhcpc.d/50default: Adding DNS 192.168.0.1

      [   29.591314] eth0: device MAC address 98:4f:ee:00:5c:61

      udhcpc (v1.20.2) started

      Sending discover...

      Sending discover...

      Sending discover...

      No lease, failing

      Starting rpcbind daemon...[   39.362025] NET: Registered protocol family 10

      [   39.455090] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

      done.

      net.ipv4.conf.default.rp_filter = 1

      net.ipv4.conf.all.rp_filter = 1

      Starting atd: OK

      INIT: Entering runlevel: 5

      Starting system message bus: dbus.

      Starting Connection Manager

      Starting OpenBSD Secure Shell server: sshd

      [   41.262575] wlan0: deauthenticating from 7c:4c:a5:54:ac:b9 by local choice (reason=3)

      [   41.342845] cfg80211: Calling CRDA to update world regulatory domain

      done.

      Starting domain name service: named.

      Starting Distributed Compiler Daemon: distcc.

      creating NFS state directory: done

      starting 8 nfsd kernel threads: rpc.nfsd: Unable to access /proc/fs/nfsd errno 2 (No such file or directory).

      Please try, as root, 'mount -t nfsd nfsd /proc/fs/nfsd' and then restart rpc.nfsd to correct the problem

      done

      starting mountd: done

      starting statd: done

      Starting system log daemon...0

      Starting kernel log daemon...0

      Starting internet superserver: xinetd.

      Starting Telephony daemon

      Starting Lighttpd Web Server: lighttpd.

      cups: started scheduler.

      Starting crond: OK

      Starting OProfileUI server

      Starting tcf-agent: OK

      Stopping Bootlog daemon: bootlogd.

       

       

      Poky 9.0.2 (Yocto Project 1.4 Reference Distro) 1.4.2 clanton ttyS1

       

       

      clanton login:

      The problem persists only in this particular image. The SD image from intel website works fine and I cannot use that image because my libraries work only with the above mentioned yocto image. Any help ?? thanks in advance

        • 1. Re: WiFi not working in yocto image
          Rushang.Karia

          The images are for outdated version as mentioned by JPMontero to you in Galileo not detected after booting from Yocto image.

          Try changing the image.

           

          If you have a smartphone try to set up a hub and check if it connects fine?

           

          If the problem persists,

          can you post your wpa_supplicant.conf file (with the credentials blurred out ofcourse).

           

          Also, did you follow the steps EXACTLY? Try copying pasting them again in the exact same order and check. Its best if you use a wifi hotspot from your phone using WPA-2 only.

          • 2. Re: WiFi not working in yocto image
            anbu369

            Hi, I tried connecting to my phone wifi now and it gives the same 'operation not possible due to rfkill' error and I cannot softunblock wifi now too. But as I said before, when I rebooted the board, the board actually connected to the phone wifi which I confirmed coz the phone showed the board as connected to it but it disconnects next moment and goes to the clanton login. Here is my wpa_supplicant.conf file

             

            Capture.JPG

             

            And this is what happens during the boot when the board gets connected to the phone

             

             

            Configuring network interfaces... Successfully initialized wpa_supplicant

            [   25.263501] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S

            [   25.276886] iwlwifi 0000:01:00.0: Radio type=0x0-0x0-0x0

            [   25.517342] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S

            [   25.530725] iwlwifi 0000:01:00.0: Radio type=0x0-0x0-0x0

            udhcpc (v1.20.2) started

            Sending discover...

            [   26.455177] wlan0: authenticate with 02:73:8d:e3:ef:77

            [   26.525934] wlan0: send auth to 02:73:8d:e3:ef:77 (try 1/3)

            [   26.536771] wlan0: authenticated

            [   26.552293] wlan0: associate with 02:73:8d:e3:ef:77 (try 1/3)

            [   26.564178] wlan0: RX AssocResp from 02:73:8d:e3:ef:77 (capab=0x431 status=0 aid=1)

            [   26.584086] wlan0: associated

            Sending discover...

            Sending select for 192.168.43.24...

            Lease of 192.168.43.24 obtained, lease time 43200

            /etc/udhcpc.d/50default: Adding DNS 192.168.43.1

            [   31.935045] eth0: device MAC address 98:4f:ee:00:5c:61

            udhcpc (v1.20.2) started

            Sending discover...

            Sending discover...

            Sending discover...

            No lease, failing

            Starting rpcbind daemon...[   41.722025] NET: Registered protocol family 10

            [   41.796897] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready

            done.

            net.ipv4.conf.default.rp_filter = 1

            net.ipv4.conf.all.rp_filter = 1

            Starting atd: OK

            INIT: Entering runlevel: 5

            Starting system message bus: dbus.

            Starting Connection Manager

            Starting OpenBSD Secure Shell server: sshd

            [   43.541190] wlan0: deauthenticating from 02:73:8d:e3:ef:77 by local choice (reason=3)

            [   43.622199] cfg80211: Calling CRDA to update world regulatory domain

            done.

            • 3. Re: WiFi not working in yocto image
              Rushang.Karia

              I am pretty sure now that the problem is due to misconfiguration of wpa supplicant. ( I had faced similar problems )

               

              Try a clean install of the SD card and follow the steps exactly. To be safe copy paste the steps.

              • 4. Re: WiFi not working in yocto image
                anbu369

                Sorry I made a blunder. I used the same method that I used for the Linux image from intel instead I should have used the one for yocto which is using connman. Now i reinstalled the image with fresh wpa_supplicant and wifi works. Thanks for all the help

                • 5. Re: WiFi not working in yocto image
                  Rushang.Karia

                  No problem man.

                   

                  Try the arduino stuff and let me know.

                  • 6. Re: WiFi not working in yocto image
                    mhahn

                    pls mark the thread as answered once answered