4 Replies Latest reply on Aug 11, 2014 8:08 AM by kaestner

    Intel Nuc D54250WYB won't startup

    kaestner

      Hi, I have an serious issue with my D54250WYB. This morning I was reinstalling Windows 7 on mSATA (before it was Windows 8.1 and I guess fast boot was turned on, I have no idea if this will change anything in BIOS, just saying it), everything seemed fine until I installed Intel drivers and the OS automatically rebooted. Then in the next boot nothing came up. By saying nothing I mean no POST, no Intel logo, no beep sound, no LED light blinking. Totally nothing.

       

      I turned off Nuc and plugged out the power, waited for 10 mins and plugged in, still the same.

       

      Then I set BIOS jump to 2-3, no change.

       

      Then I used BIOS recovery mode and plugged in USB drive with BIOS update file, this time The screen showed Intel Nuc and it went through with updating BIOS successfully.

       

      Next boot, still the same, nothing.

       

      I've tried remove everything, mSATA, Wireless. Also plugged in and out the RAM (FYI, no RAM alarm all the time)

       

      Now I don't know what to do. Help please