3 Replies Latest reply on Aug 25, 2014 8:28 AM by aslloyd

    Weird problem with X540-AT2 and Cisco switches

    flindgren

      Hello,

       

      I'm having a weird problem with two servers using Supermicro 9SRH-7TF boards and the onboard Intel X540-AT2 based ports. The ethernet ports come up as 100mbps/full duplex. This is happening with two different Cisco switches, one 2960G and one 7609 with a 48port Gb card. Cabling is Cat6, 15 meters for the 7609 and 3 meters for the 2960G.

       

      The servers are running Debian Wheezy and I've tried the stock Debian 3.2.0 kernel as well as the latest kernel from kernel.org (3.14.15). I've also tried using the latest ixgbe driver from sourceforge to no avail.

       

      I was obviously expecting it to come up at 1gbps. But all ports come up *** 100mbps/fdx.

       

      If I change the advertised modes from the server end to only include 1gbps/fdx the link goes down. Setting "speed 1000" on the Cisco also causes the link to go down.

       

      Anyone seen something like this?

       

      Regards,

      Fredrik Lindgren

        • 1. Re: Weird problem with X540-AT2 and Cisco switches
          aslloyd

          Hi Fredrik,

           

          There have been instances where something in the port configuration has an unexpected negative effect, but for starters let's look at how the network port(s) perform on their own.

           

          What link speed do you get if you wire the 10G ports to one another (so no switch in between?)  Does this change using shorter and longer cables?

           

          Thanks!

          south

          • 2. Re: Weird problem with X540-AT2 and Cisco switches
            flindgren

            Hello,

             

            Sorry for the delay, but now I've been able to test some more.

             

            When connecting the ports on the server directly with the same cables I've been using to connect to the switch the ports come up in 10G immediately. I also got some new, presumably higher quality Cat 6A cables. These give the same behavior when used to connect to the Cisco switches, 100Mbit FDX. When connected in a loop between the ports on the server the new cables also produce an instant 10G connection.

             

            Also, when messing with the cables, it came up as 1Gbps once. However, removing the cable and reattaching it produced 100Mb next time.

             

            It feels like an issue with the auto-negotiation between the ethernet controller and the switch? However, I've been unable to find anything similar online.

             

            The switches are:

             

            Cisco 7609:

            Ethernet board: WS-X6748-GE-TX CEF720 48 port 10/100/1000mb Ethernet Rev. 2.4

            Software: Version 12.2(33)SRE9, RELEASE SOFTWARE (fc2)

             

             

            Cisco 2960G:

            Model: WS-C2960G-24TC-L

            Software: Version 12.2(44)SE6, RELEASE SOFTWARE (fc1)

             

            Regards,

            Fredrik Lindgren

            • 3. Re: Weird problem with X540-AT2 and Cisco switches
              aslloyd

              So next let's take a look at the configuration of the switch ports.  Would you please send me exported configs at south.lloyd@intel.com?