3 Replies Latest reply on Aug 4, 2014 8:54 AM by flummer

    How to Upload (OS X 10.9.4)

    Kirasan

      I'm an experienced Arduino Uno user who is new to the Intel Galileo development board. I've been able to select the /dev/cu.usbmodem##### as my serial port, and I get no errors uploading (upload messages end with "Transfer complete # #").

       

      However, I am unable to print to Serial:

       

      void setup(){ Serial.begin(9600); }

      void loop(){ Serial.println(5); }


      Gives, on the serial monitor, "** B0100000063f694", but no repeating messages, and certainly no fives.

       

      And I am similarly unable to control the power to an LED. I run the following,

       

      void setup(){

        pinMode(ledPin,OUTPUT);

        digitalWrite(ledPin, LOW)

      }

       

      void loop(){ }

       

      and the LED stubbornly remains in its strange behavior of  turning on when I plug it into an analog or digital pin. (regardless of what code I send its way). Has anyone gone through this issue? If so, how can I fix it?

       

      Please ask if you need more information

        • 1. Re: How to Upload (OS X 10.9.4)
          flummer

          Hi Kirasan,

           

          Are you able to run the blink sketch and have the LED blink (no code changes should be necessary)?

           

          It sounds like something is crashing and the program isn't running correctly on the board.

           

          Have you updated the firmware to the latest version? Are you running the OS from SD card or from the onboard SPI flash?

           

          Do you use the latest Galileo specific IDE and have you selected the right version of the Galileo board under Tools -> Board?

           

          /Thomas

          • 2. Re: How to Upload (OS X 10.9.4)
            Kirasan

            I've run the blink sketch, but the LED does not blink - it just stays on when plugged into pin 13.

             

            The SD card slot is empty. I'm running the Galileo from the micro USB client cable.

             

            Yes I am using the Galileo specific IDE, and have selected the right version (NOT gen2) of the Galileo board under Tools -> Board.

             

            Yup - The firmware update did the trick - the blink sketch works now! Thanks so much!

            • 3. Re: How to Upload (OS X 10.9.4)
              flummer

              I'm glad to hear that it helped with a firmware update. It doesn't really makes sense, but something must have gone corrupt.

               

              I'm running the Galileo from the micro USB client cable.

               

              I don't know exactly what you mean by this, but if you don't have an SD card inserted (or any other mass storage devices) the board will boot the Linux OS from the on board SPI Flash, the USB client connection is only for sketch upload and debug information.

               

              One of the differences between this board and a regular Arduino Uno is that there is an OS running on the board, and the sketch you write in the Arduino IDE will compile into a program that runs on top of the OS, not directly on the hardware as on a micro controller.

               

              And just to be sure, always use the supplied PSU with the Galileo board, powering it ONLY via USB isn't gonna work (for long) and might damage the board.

               

              /Thomas