5 Replies Latest reply on Aug 7, 2014 8:15 AM by Paul_Eggleton

    problem of yocto enviroment

    LeiZhou

      Hi,

      I am trying to build yocto in a server enviroment(SUSE), which means I can not install software package so easily. The sanity checker showed that I have version problem, but which git showed a higher version.

      How can I solve this problem?

      Thanks.

       

      Lei

       

      plxc15034:/nfs/pdx/disks/rriver03/zhouleix/MyWorkspace/IHL2/yocto/micro/build> bitbake image-micro

      WARNING: Host distribution "SUSE-LINUX-11" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.

      ERROR:  OE-core's config sanity checker detected a potential misconfiguration.

          Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).

          Following is the list of potential problems / advisories:

       

          Please use a umask which allows a+rx and u+rwx

      Your version of git is older than 1.7.5 and has bugs which will break builds. Please install a newer version of git.

      Please install the following missing utilities: chrpath

      The TMPDIR: /nfs/pdx/disks/rriver03/zhouleix/MyWorkspace/IHL2/yocto/micro/build/tmp can't be located on nfs.

       

      ERROR: Execution of event handler 'check_sanity_eventhandler' failed

      ERROR: Command execution failed: Exited with 1

       

      Summary: There was 1 WARNING message shown.

      Summary: There were 3 ERROR messages shown, returning a non-zero exit code.

      plxc15034:/nfs/pdx/disks/rriver03/zhouleix/MyWorkspace/IHL2/yocto/micro/build> git version

      git version 1.8.2

      plxc15034:/nfs/pdx/disks/rriver03/zhouleix/MyWorkspace/IHL2/yocto/micro/build> cat ~/.itools

      # By default, use the latest for everything

      * latest

      # The latest gcc is usually fine.

      # If you set a specific gcc version for some reason,

      # you must use a version >= 4.6.2

      P:python 2.7.5

      P:gcc 4.8.0

      P:git 1.8.2

      P:tar 1.26