12 Replies Latest reply on Aug 20, 2014 5:59 PM by aldergrovegeek

    I need RSTe GUI for Server 2012 R2


      I have just installed Windows Server 2012 R2 Standard on a new SuperMicro server running an X10SAE MB.  It has a Intel C226 Chipset.


      It seems that Server 2012 R2 has come with a newer version of drivers for the RAID/AHCI as every time I try to install the IATA_CD download from either SuperMicro or Intel, it give me a message that says:


      "The computer currently contains driver versions newer than the versions you are about to install. Are you sure...."


      I have tried a couple times to install anyway as I want to get the GUI up and running so I can use it's features etc.  However each time seems to result in the system becoming highly unstable.


      Any advice that can be offered would be great.  Thanks

        • 1. Re: I need RSTe GUI for Server 2012 R2

          The IATA_CD I see online has a modified date of 9/26/2013, to go along with driver version


          If you look in Device Manager, what date and version of the iaStorS.sys are currently installed?

          • 2. Re: I need RSTe GUI for Server 2012 R2

            Thanks for the Reply Dan,


            I just checked and the Driver Version that Windows Server 2012 R2 installed is for the C600 Series Chipset.  While this motherboard has a C226 Chipset. 


            the version number shown is actually and the date is 8/9/2013


            Interestingly Supermicro support send me links to version  They have a date of 28/1/2014.  I am tempted to install them even though they are still telling me that the version I have running is newer than the ones installed....


            I hope I don't have to restart the process with these drivers.  It would be a lot of work.  I hope this new set works.


            What are your thoughts.

            • 3. Re: I need RSTe GUI for Server 2012 R2



              From the device manager, I pointed the controller to the folder where the drivers were sitting and it installed them without complaining.  However when it rebooted, it hung at the boot stage.  After about 15 minutes of waiting for something to happen (Gets irritating watchin them little dots keep going round and round...) i reset the system and did a last know good and it is back up and running.


              Is there a safe way to install these drivers without forcing me to re-install the whole system.  There is no data currently installed, so starting over is not the end of the world, it would just be inconvenient...


              Please advise.

              • 4. Re: I need RSTe GUI for Server 2012 R2

                I would be pretty hesitant to use C600 drivers on a C226 board.  I would first try uninstalling any C600, then do a clean install of the C226


                If that doesn't work, I would probably wipe the whole thing clean and start over.  If you leave it in its current state, you run the risk of future instability and unpredictability, especially if you ever do further driver updates.

                • 5. Re: I need RSTe GUI for Server 2012 R2

                  That was my thought as well.  It is also the response I got from Supermicro tech Support.


                  So far this has been a struggle.  I have tried the drivers provided by supermicro several times, each time with varied success (or failure).  Once I actualy got server to install and boot properly.  However it invariably crashed without chance of recovery while performing the first batch of Windows updates.


                  Since then I have tried several times. and the system has invariably frozen somewhere in the "Getting Files ready for Installation (XX%)  the percentage is never the same.  Some Drive 0 is lit up, sometimes drive 3... its not consistent. I am trying to use RAID 5 with 4 WD SE 2GB drives but so far no luck.


                  I am starting wonder if I need to run WD Align, but the support files say it shouldn't be necessary.


                  Incidentally, on the assumption that it is a driver issue, I went back to the driver listed on supermicros site and tried them, just in case it was a driver version issue.  Still no luck.  It still froze at 40% with Drive 0 lit up.


                  BIOS? RAID? MB? a Drive? or cable?  Not sure where the problem lies at this point.  This is getting frustrating.  This project is at a standstill untill i can get this sorted out.

                  • 6. Re: I need RSTe GUI for Server 2012 R2

                    On a whim... Cause I have nothing better to do on a Tuesday night.... I set the SATA config in the BIOS back to AHCI and pulled all the drives but one.  I then tried a fresh install without RAID.  This time It got to the first reboot... but then the whole system froze....

                    • 7. Re: I need RSTe GUI for Server 2012 R2

                      And so like a Lemming, I went back again and tried re-enabling the RAID function, but turned off the "Security/Freeze" option in the BIOS... and this time it made it to 31% and Froze with Drive 2 lit up.


                      So Now I am thinking this could be either a BIOS/MB or Backplane Issue... but that's enough for tonight...  tomorow I will pull the machine and make sure all looks OK inside, Flash the BIOS and Try again.


                      What Fun!

                      • 8. Re: I need RSTe GUI for Server 2012 R2

                        Has anyone solved this issues yet? I'm having the same problem on an Intel S1200RP motherboard.

                        • 9. Re: I need RSTe GUI for Server 2012 R2

                          No solution yet.  Gonna be tackling it later today.   Still assuming its a hardware issue but haven't narrowed it down much yet.

                          • 10. Re: I need RSTe GUI for Server 2012 R2

                            Update time!


                            I have now taken this machine through several rounds of trial and error diagnostics to try and Isolate the problem.


                            First I ran Memtest 86+ v4.2 for about 36 hours.  11 passes with no errors.


                            Next I disconnected the the Back Plane and used a new SATA cable and a 500GB WD Black (new) i had sitting around and did a simple install onto this drive.  BIOS was set to AHCI (no RAID) for the drives.  This worked great, no errors.


                            Next I put the same drive into the Front Trays and plugged in only bay 0 on the Back Plane and did the same install as above.  no errors.


                            Next I Put one of the 2TB WD Se drives into the same bay and repeated the above.  No errors.


                            Next I plugged in Bay 1 and switched the BIOS to RAID.  Setup a RAID 1 array and performed the above install.  The main difference here was that I also needed to install the RAID drivers for the windows install, and install the RAID GUI into windows and initialize the Array.  Took longer this time, due to the time taken to Initialize, but otherwise completed without errors.


                            Just now, Instead of proceeding to a RAID 5 setup like I had been doing before, I instead decided to experiment with a storage pool instead.  I shut the machine down and plugged in the rest of the drive bays.  Now there are x6 2TB WD Se drives in the machine.  0-1 are a RAID 1 set, the other 4 (2-5) are simple drives.  It seemed to boot fine, however when I went into the file and storage manager in the Server manager software, and clicked on one of the drives shown, the system hung.  The Mouse still moved, but nothing responded.  And now Bay 5 is lit up!


                            So Now I need to wonder if this is a Drive error problem, a Back Plane issue, cable issue..... [*sigh*] ... more testing.....

                            • 11. Re: I need RSTe GUI for Server 2012 R2

                              When you were using 4x 2TB drives in RAID 5, was UEFI mode on or off?

                              • 12. Re: I need RSTe GUI for Server 2012 R2

                                So after much trial and error, I belive I have narrowed it down to the SATA-743 Backplane from supermico as the problem.  After several attempts at different configurations, and random failures, I was able to achieve 100% failure rate every time I attempted to build a Storage pool with Parity.


                                For my next attempt, I removed all the drives from the front bay and plugged them directly into the MB, effectively bypassing the Backplane.  This time it built the Storage pool perfectly.  I am going to attempt a few more things on this machine before declaring this solved.  but looks like I have either bum hardware or something related.  (maybe a missing connection or something... need to do some reading.)


                                Gize, I believe the UEFI is turned on, but I haven't confirmed that as of yet.


                                Somehow I doubt the client will accept the server in its current state.... Must get this resolved.