7 Replies Latest reply on Aug 7, 2014 7:07 AM by neo38m

    Imaging NUC's using wds not working because usb does not work

    neo38m

      please help me, I am trying to image some of the new NUC's we received using wds, no matter what I try I cannot seem to get the usb to respond, I have installed windows 7 and 8.1 (2 different times) and when I install the drivers all seems to be ok but the moment I try to capture or push an image onto these units it does not seem to work and I the keyboard and usb do not work. model no is D34010WYK

        • 1. Re: Imaging NUC's using wds not working because usb does not work
          sylvia_intel

          Hello Neo38m, I'm sorry for the inconvenience you have faced when trying to installed an image on new NUCs.

          It is very important to let you know that we support "stand along installations".  Fos us , if you are able to installed the operating system, with all  required drivers and it is working fine, means that  the NUC is workings as expected.

           

          If you are still going to use an image on the new NUCs, try reliable image software.

           

          These types of installations can cause many issues similar to the one you are reporting. This is not due to an incorrect functionality of the NUC. Bear in mind that this procedure is out of our scope.

           

          Thanks for your understanding.

          • 2. Re: Imaging NUC's using wds not working because usb does not work
            neo38m

            ok well luckily we have only brought around 150 of them so I guess we wont be purchasing anymore, you see I work for a school and I need to replace around 800 or more units, I am not putting an OS on 800 or more unit manually.

            • 3. Re: Imaging NUC's using wds not working because usb does not work
              Mr Harvey

              Neo38m,

               

              did I understand you correctly that you currently have an image of the NUC?  And you want to push (i.e. restore) that image onto the other NUCs to avoid installing them from scratch?

              If so, I have seen there are/were some issues using external/USB WD disks on USB 3.0 ports but at this point it is not certain was it due to WD drivers, or USB 3.0 host controller drivers.

               

              If you say the USB disk is working before you start making the image, there might be an issue with your imaging software (if Windows detects and uses the drive properly). Which imaging SW did you use?

               

              Anyway, I would advise you to check this fine article on MyDigitalLife, and use the Macrium Reflect disk imaging software (free edition is enough) in combination with WinPE (Macrium Reflect can create the WinPE rescueCD or ISO, or make an bootable USB stick, and you can then integrate the required USB driver(s) into your WinPE boot.wim using the info provided on the mentioned link).

              If you're using USB3.0 devices, an added benefit is that the image restore procedure described on this link will enable you to work with maximum USB 3.0 speed.

               

              I have tested this procedure (albeit using WD external USB 3.0 drive and D54250WYK NUC) and can confirm it is working - i.e. image restore was successful over USB 3.0 port. You will need to check/investigate which USB driver files to integrate into boot.wim though - but once you do that, restoring the image on the other NUCs should go fine. I would recommend to integrate your NUC's Intel USB drivers (and possibly the WD drivers, although that should not be necessary).

               

              A bit off topic, but - when you installed the drivers on original NUC (i.e. the one you're imaging), did you install them one by one (rebooting after each installation), and beginning with Intel INF files, then Intel ME driver first?

               

              Also, if you're managing a school LAN and have a DHCP server and a NAS hooked up to the LAN, you can even put the NUC image files on the NAS, integrate the NUC LAN drivers into the boot.wim using the above procedure, and then just download the image from NAS. This can take some more time to get it working but it could save you some serious time on image restoring; Intel usually provides the WinPE LAN driver (at least for D54250WYK), however I was not yet able to get the LAN working inside WinPE (but then, I have only 1 NUC so I don't mind using USB).

               

              Regards,

              /HarveyV

              • 4. Re: Imaging NUC's using wds not working because usb does not work
                sylvia_intel

                Neo38m, I found the following video from our site, on how to create a slipstream.

                 

                http://www.intel.com/support/motherboards/server/sb/Creating%20Slipstream.htm

                • 5. Re: Imaging NUC's using wds not working because usb does not work
                  chrisw214

                  Last year, I was researching for a customer of mine and saw a solution called FOG Overview | fogproject.org

                   

                  This solution allows for mass imaging and management.  While I do not have first hand experience with this, you may want to check it out as it looks very robust and it looks like many educational institutions use it because of the way it scales.

                   

                  Let me know if this is any help.

                   

                  Thanks.

                   

                  Chris

                  • 6. Re: Imaging NUC's using wds not working because usb does not work
                    neo38m

                    Thanks for all your suggestions, we tried Fog and it was not that great to be honest.

                    and to answer Mr Harvey, I don't want to use winpe as an os.

                    WDS is a Microsoft product which has worked for a million other computer products (including intel boards) this is the first product that has had issue's and before you ask I have tried attaching a set of drivers packages to a boot image in wds but that did not work (where it normally does)

                     

                    however I have not used Nlite? interesting so I am going to give that a go and see where that leads me.

                     

                    It might take me a while to test this because I have just had a 100 grand worth of networking gear land on my door step and now needs configuring and rolling out.

                    • 7. Re: Imaging NUC's using wds not working because usb does not work
                      neo38m

                      ok just tested Nlite, looks good but its still not a viable option.

                       

                      I have an image from pre built computer with all the relevant software ect, I don't want to install all these software on all 800 nuc's?

                       

                      that's just crazy, ok so yes I have software deployment tools like pdq but that's not the point.

                       

                      the point I am make is WDS is the industry standard I have used it in major organisations like the NHS and british gas ect so I don't see what the issue is?

                       

                      I think one of you mentioned that it could be USB3, and I think that's where the problem lies.

                       

                      Windows 7 WDS Deployment - USB 3.0 Driver Package Won't Install