7 Replies Latest reply on Feb 23, 2015 10:30 PM by Samkit_Surana

    Boot OS from the SD card

    tsvetan.filev

      Hi.

       

      I have an Intel Galileo board from few months. I would like to boot a larger OS with more capabilities from the SD card. I downloaded the latest IDE 1.5.3 and updated my FW to the latest one 1.0.0.

      I then downloaded LINUX_IMAGE_FOR_SD_Intel_Galileo_v1.0.2 from Intel web site (Software Downloads - Drivers) and copied it to Hama 32G HC SD Card but grub was not able to find the image.

      So I tried with Kingston 8G HC SD card and I was able to boot successfully.

       

      Then I downloaded a virtual applience from Yocto project page, read the documentation and compiled my own yocto image with more packages (apache, php, mariadb, etc). I was not able to boot it. I then tried with images from here Intel-NTU Connected Context Computing Center (Clanton_Full_SDK_OpenJDK6_Tomcat7), Clanton Simple image and also again with LINUX_IMAGE_FOR_SD_Intel_Galileo_v1.0.2 but always got this screen:

       

       

      I can see that grub cannot find it's configuration but it exists on the SD Card:

       

       

      Here is the contents of grub.conf from LINUX_IMAGE_FOR_SD_Intel_Galileo_v1.0.2:

       

      =============================

      default 1

      timeout 1

       

      color white/blue white/cyan

       

      title Clanton SVP kernel-SPI initrd-SPI IMR-On IO-APIC/HPET NoEMU

          kernel --spi root=/dev/ram0 console=ttyS1,115200n8 earlycon=uart8250,mmio32,$EARLY_CON_ADDR_REPLACE,115200n8 reboot=efi,warm apic=debug rw

          initrd --spi

       

      title Clanton SVP kernel-MassStorage initrd-MassStorage image-full IMR-On IO-APIC/HPET NoEMU debug

          root (hd0,0)

          kernel /bzImage root=/dev/ram0 console=ttyS1,115200n8 earlycon=uart8250,mmio32,$EARLY_CON_ADDR_REPLACE,115200n8 reboot=efi,warm apic=debug rw LABEL=boot debugshell=5 rootimage=image-full-galileo-clanton.ext3

          initrd /core-image-minimal-initramfs-clanton.cpio.gz

      =============================

       

      I formated the SD card with different allocation units: 4k, 8k , etc. and FAT32 but that makes no difference.

       

      Can you tell me what might be wrong or how can I debug what the problem is ?

       

      P.S. I have read the rest of the questions in this forum and tried everything but with no luck.

        • 1. Re: Boot OS from the SD card
          JPMontero_Intel

          Hi tsvetan.filev

           

          Make sure your card is not partitioned, also try downloading the new IDE and update the board firmware to 1.0.2 and try again with the LINUX_IMAGE_FOR_SD_Intel_Galileo_v1.0.2 and let us know your results. If that doesn’t work I’d say you could try with a smaller SD card, I guess that might be the problem. I hope you find this helpful.

           

          Regards,

          JPMontero_Intel

          • 2. Re: Boot OS from the SD card
            mhahn

            not completely sure whether relevant: have you set the 1st partition of the SD card bootable?

            • 3. Re: Boot OS from the SD card
              AlexT_Intel

              For the method galileo uses, that's irrelevant.

               

              tsvetan.filev, are you running this off of the 8GB card you've tested as working? If yes, then maybe the card formatting got messed up during trials of various block sizes, I'd suggest you to try the "SD Card Association formatting tool" as it's supposed to provide the most "correct" formatting layout. Or try a different card.

               

              And by the way, you mentioned that you have updated the board's FW to the "latest 1.0.0". The latest one is 1.0.2, so make sure you're on it. Maybe it's worth redownloading the IDE and flashing the board again.

              • 4. Re: Boot OS from the SD card
                Rushang.Karia

                Hi.

                 

                As the others pointed out, please upgrade your board firmware. Also note that most of the images of the NTU website were for firmware 0.7.5 so do not use them.

                 

                Now to bring your SD-card to its default condition.

                Goto Control Panel -> Administrative Tools -> Disk utility.

                 

                Select your SD-card, and delete that partition.

                Now goto MyComputer -> Right click on the drive and click format.

                Keep the block allocation size as default. and the format method to FAT. If you do not have FAT as an option you will need to use diskpart.exe accessible from the command prompt/

                Instructions to do this are given in the Intel Galileo Documentation.

                 

                This will ensure a clean -good-as-earlier SD.

                 

                Now, try the official Linux Image and check if it works. If yes then you can try bitbaking your way to glory using the latest BSP build guide.

                 

                Mahn The UEFI BIOS does not search the SD-card for the magic # so the SD-card sector need not be bootable.

                • 5. Re: Boot OS from the SD card
                  tsvetan.filev

                  Hi all.

                   

                  Thanks for all the suggestions.

                   

                  Here is what I did:

                  1. I downloaded the latest IDE and Official Linux Image

                  2. I updated the FW of my board to 1.0.2

                  3. On my linux box (opensuse) I checked the partitions of the SD card with fdisk and you are right after all my tries I found out there was more than one partion

                  4. I used "SD Card Association formatting tool" ( SD Formatter 4.0 for SD/SDHC/SDXC - SD Association ) to format my card and here is what it did:

                   

                  fdisk /dev/sdb

                   

                  Command (m for help): p                                                                                                                                                                                                                                                       

                                                                                                                                                                                                                                                                                                

                  Disk /dev/sdb: 7822 MB, 7822376960 bytes, 15278080 sectors                                                                                                                                                                                                                    

                  Units = sectors of 1 * 512 = 512 bytes                                                                                                                                                                                                                                        

                  Sector size (logical/physical): 512 bytes / 512 bytes                                                                                                                                                                                                                         

                  I/O size (minimum/optimal): 512 bytes / 512 bytes                                                                                                                                                                                                                             

                  Disk label type: dos                                                                                                                                                                                                                                                          

                  Disk identifier: 0x00000000                                                                                                                                                                                                                                                   

                                                                                                                                                                                                                                                                                                

                     Device Boot      Start         End      Blocks   Id  System                                                                                                                                                                                                                

                  /dev/sdb1            8192    15278079     7634944    b  W95FAT32                                                                                                                                                                                                             

                  5. I copied the Offical Linux files on the SD card and it now works fine.

                   

                  So yes there is "correct options" for the SD card file system but I'm not sure what they are. Probably the tool chooses them automatically based on the SD card size or something.

                  Anyway it now boots and works fine.

                  I will now try to bitbake my yocto build and try to boot it.

                  I will probably have more questions but I will start a new discussion ;-)

                   

                  Thank you.

                  • 6. Re: Boot OS from the SD card
                    tsvetan.filev

                    Hi again.

                     

                    Just FYI I tried also with my 32 GB card and this approach also works.

                    So I confirm that both 8 GB and 32 GB cards work but one should be carefull about the "correct" partition/file system setup of the SD card.

                     

                    Regards.

                    • 7. Re: Boot OS from the SD card
                      Samkit_Surana

                      Hi,

                      I am Samkit Surana, trying to perform a Fnal Yera Engineering poject on INTEL GALILEO GEN2, i am facing the problem when i am trying to boot IoT os image (from:- IoT Download - Board Boot Image ) and i followed the standard procedure for running it (from:- Appendix I )but still i am not able to boot this OS.

                      on putty when i entered serial communication it ask for clanton login  & password.

                      this is the same problem as shown abovw is faced by me, plz hlp me out..

                      i am stop here.

                      plz help.